Write failures in Mac Version 1.2.0 (48)


Select all tracks. Nav to Discogs as the tag source. Enter album and artist. Search. Select desired release. "Save". Every attempt to write the tags fails with a permission problem. Verifying permissions shows that I own the files and have RW access.
Manually filling in the tag info one track at a time and updating that one track succeeds. So it's unlikely that the problem is file permissions.
Tried this on both disk and thumb drive files with the same result.
Note: Using the tag search feature to update a single track also fails with a permission problem. Seems like this has to do with the tag source "save".

Update: It appears that the failure is related to the image. I can update the details for any track manually except for the cover art. Trying to add cover art results in the error message "can't write..."

Do you see any details on this error message in Console.app when you search for Mp3tag? You'd need to have Console.app open while reproducing the issue.

It seems to me that Mp3tag isn't allowed to create temporary files on your external volume. Loading the root of that volume might give Mp3tag permission to do so and might make the error disappear.

I'll give mp3tag full disk access and access to external volumes and see if the problem resolves. It is odd (since I don't know how you implemented it) that I can write everything except cover art. I'll report back.

Granting full access to mp3tag solved the problem. Coincidentally during the test I noticed that a LP I had ripped via Audacity had tracks incorrectly delineated. I went into Audacity to fix the problem and recreate the tracks. When I went to write out the result Audacity informed me that it didn't have permission to access the drive the files were on and prompted me to grant access.
It would be great if mp3tag could prompt for access, too.
Thanks for the help, Florian!

Can you give details about the CARMUSIC drive (e.g., USB/Network, file system, ...)? I've tried to reproduce it with no success.

As background information: Mp3tag gains secure sandbox access when you drag and drop a file to its window or if you open it via an open panel. If it needs to create a temporary file during tag writing (often when adding covers, where existing free space in the file isn't sufficient), it asks the system for a place where it is allowed to create such files. It seems that this part doesn't work in your case.

I keep forgetting that I can't reply to the community emails you send. Sigh.

CARMUSIC:

2021-06-03_10-42-09

Since granting Mp3tag full disk access pretty much everything now works. My observation was that most apps request to be granted disk access if they fail to open a device for read or write. I've never seen Mp3tag pop that dialog (including an offer to startup the Security and Privacy preferences.

I am doing this on a Intel Mac running Catalina. That's where most of my storage is attached. I have a M1 MacBook Air (Big Sur) that I also run Mp3tag on just for playing around with features.

In general I wouldn't grant Full Disk Access to an application that didn't strictly need it. However since I have music storage split across multiple devices I have to grant access or I'd be forever running into restrictions.

My iTunes storage is a partition on a Drobo. CARMUSIC is a partition on a USB drive. Finally the thumb drive is used to move music to the car.

FWIW BMW infotainment systems are very fussy with regard to tags. Any image over 500 square pixels will not display. I know JPEG images work, but I have not experimented to see if PNG or other formats work. Any file with an unsupported extension (regardless of content) is ignored and the entire directory containing the unsupported file type is inaccessible from the iDrive UI. At least my current BMW supports a variety of formats including flac and m4a (mp4 is unsupported obviously). The previous car, which I owned while starting to use Mp3tag, had very limited file and format support.

Without Mp3tag the entire process of moving thousands of files to the iDrive environment would have been much less rewarding. I know. I tried. :frowning:

Thanks again, Florian.

-Gary