Wrong/Different Tags Displayed


Hi everyone,

I've got a little problem, which is that the tags I have set in mp3tag are not the same as shown in Windows Explorer and for example VLC, as can be seen here:

I've tried renaming the files so they get indexed again and using mp3val to "fix" the files. Both didn't work.

Any help would be very appreciated!

Kind regards


which tag versions / type have got in the files? ID3V2 only or also APE?


Hovering over the .mp3, dbPowergamp gives me some information about it:

It says APEv2 & ID3v2.3 and there is a ton of tags from albumkings.com (where I got it from appearently, can't really remember) aswell.

EDIT: going through the albums where this happens, I think the reason is the APE thing


You should get rid of the ape tags.
In MP3Tag Appe tags dominate the tag-view. If there are ape-tags they are shown and you don't see the ID3V2.3-tags.


It can help to have a column defined and activated within Mp3tag column view:
Name: TagRead (TagTypes)
Value: %_tag_read%[' ('%_tag%')']



What's the best way to do this? I've tried just copying the tags, removing them and then pasting them again, which worked out. But doing this with ~100GB worth of mp3's would take forever, since first of all it just takes ages to remove and apply the tags, but adding to that when I remove the tags there are random files being left out, which I would have to remove manually, I think you get what I mean. Surely there must be a better way :slight_smile:


In general this should work:

  1. Within "Mp3tag/Tools/Options/Tags/Mpeg" ...
  • set the tagtype to be read;
  • set the tagtype to be written.
  1. Press [F5] to refresh the listview resp. load the files to work on.
  2. Within the listview select the files to work on.
  3. Select "File/Save tag [Ctrl+S] to write, what has been read.
  4. Within "Mp3tag/Tools/Options/Tags/Mpeg" ...
  • set the tagtype to be read to the tagtype, which has been written.
  1. Refresh the listview.
  2. Check the copied data. If all has been done well, then remove the unwanted tagtype from the files, or just leave them within the files and set the options to never read the unwanted tagtype.



Worked perfectly! Thanks a lot to you and everyone else for helping me sort this out :slight_smile: