[WS] Discogs (pone mod)

Just updated to 2.69, but still no images when using standard search from pone 4.4.
Do I need to reinstall the pone mod?

yup - same here

cover art not working to me (v2.96) (pone 4.4)

Any ideas if we can get this working? Thanks :slight_smile:

after a long time of 'not tagging' i wanted to restart w/ mp3tag 2,69 and Discogs_Pone_Mod_4.4. i always search via discogs id; i get no album, title and cover but things like www, publisher, albumartist, things i deleted before creating the script.

It seems that the cover download is still not working.
The other information (title, artist, album, ...) works fine with the script. Maybe it helps to review or reset the settings file.

here is a workaround for the cover:

Discogs images

I'm currently re-writing my own set of scripts to suit my needs .. there is a new thing to parse discogs more easily with json commands.

I might post later what I come with, if you still need a working discogs script you can use the one bundled with mp3tag.

hmmm, i used this script:

WS Discogs Album search...

Its based on Pone and also not working after late Feb.

I modify the script and it works fine for me. At the beginning i added the JSON "ON"...

[ParserScriptIndex]=...
#?
[ParserScriptAlbum]=...
# Pone Mod 4.1
# debug "on" "C:\debug.txt"
json "ON"

#< ## Totaldiscs # 
outputto "totaldiscs temp"

and at the end added

# Coverurl
outputto "coverurl"
json_foreach "images"
    json_select "type"
    if "primary"
        json_select "uri"
        say "http://cache.mp3tag.de/coxy"
        sayregexp "(?<=\.com).*"
        #sayrest
    endif
json_foreach_end
QUOTE (The Zyc @ May 5 2015, 00:25) <{POST_SNAPBACK}>
and at the end added
# Coverurl
outputto "coverurl"
json_foreach "images"
    json_select "type"
    if "primary"
        json_select "uri"
        say "http://cache.mp3tag.de/coxy"
        sayregexp "(?<=\.com).*"
        #sayrest
    endif
json_foreach_end<!--QuoteEnd--></div><!--QuoteEEnd-->

it will only work if discogs release got only 1 primary image, if it has secondary images or multiple primary images it won't work.

Okay, sorry... I have tested this workaround with a selection from 8-10 Albums, and one of this has no Cover. I meant no harm by it

What went wrong? :frowning:


did you authenticate your mp3tag application in the discogs?

mp3tag should ask you to do that first time.

Yes, the normal Discogs function works.

Hi,
does anyone find a way to get the images from Discogs via pone's script by a modification or will pone upgrade this great script?

I tried the JSON method but it did not worked for me. Maybe I did something wrong and someone could add a working script for album search here, so I can do a diff.

Or did Discogs found a way that it is not possible anymore?

read few posts before I've posted a link for workaround for images ..

[WS] Discogs (pone mod)

Thanks mp3taglover for telling me that it should work... And now I managed it. I did a complete reinstall and then added the JSON script - I got my images :slight_smile:

Why do I get this ugly formation under DISCOGS_FORMAT

When Discogs page under Format: clearly has less words.

http://www.discogs.com/Jimmy-Ruffin-Sings-...release/3759671

My settings for FORMAT:

Format (complete):            >DISCOGS_FORMAT

Mediatype:                 >
- with quantity            >yes

Description Category:        >
Description Text:            >
QUOTE (Moshi @ Oct 7 2015, 01:32) <{POST_SNAPBACK}>
Why do I get this ugly formation under DISCOGS_FORMAT

When Discogs page under Format: clearly has less words.

http://www.discogs.com/Jimmy-Ruffin-Sings-...release/3759671

My settings for FORMAT:

Format (complete):            >DISCOGS_FORMAT

Mediatype:                 >
- with quantity            >yes

Description Category:        >
Description Text:            ><!--QuoteEnd--></div><!--QuoteEEnd-->

I do not have this field, but in FORMAT field everything is correct:

for FORMAT i have this code:

# Media Type
json_foreach "formats"
    outputto "Format"
    json_select "qty" 
    ifnot "1"
        sayrest
        say " x "
    endif
    json_select "name"
    sayrest
    json_select_array "descriptions" -1 ", "
    ifnot ""
        say ", "
    endif
    sayrest
json_foreach_end
QUOTE (mp3taglover @ Oct 7 2015, 01:37) <{POST_SNAPBACK}>
for FORMAT i have this code:
# Media Type
json_foreach "formats"
    outputto "Format"
    json_select "qty" 
    ifnot "1"
        sayrest
        say " x "
    endif
    json_select "name"
    sayrest
    json_select_array "descriptions" -1 ", "
    ifnot ""
        say ", "
    endif
    sayrest
json_foreach_end<!--QuoteEnd--></div><!--QuoteEEnd-->

What the hell... This brakes my plugin. :smiley:

What am I doing wrong?

you need to open %appdata%\mp3tag\data\sources\discogs_pone_script.src (not sure about script name it might be different, as im using my own script based partly on pone)

and add there (maybe at the end):

json "ON"
# Media Type
json_foreach "formats"
    outputto "Format"
    json_select "qty"
    ifnot "1"
        sayrest
        say " x "
    endif
    json_select "name"
    sayrest
    json_select_array "descriptions" -1 ", "
    ifnot ""
        say ", "
    endif
    sayrest
json_foreach_end

I'm using modified script kinda mixed of pone_mod and discogs_xml_all adjusted to support json discogs API, let me know if you'd like to have my whole script.

I might but I find it a bit too confusing for me..

What are major differences between your custom script and default one that I'm using?