[WS] Discogs (pone mod)

Not quite working!

Here is a better version, seems to work on releases with single or multiple images. Not that efficient though with two loops. Moved the json "on" command to the bottom also this time.

Discogs__Pone__Direct_by_Discogs__ID.src (19.1 KB)

Thank you, but I use "Direct by URL". Not working, so previous posts saying to replace http with https are wrong.

Here is the error:

Where is the topic author?

Did you mean chapters under:

?

If so, it's already implemented in DISCNAME tag:

He's no longer here to maintain his script for few last years, busy in real life I guess.

Yep, that was it. Excellent, with a bit of some editing, got it to tag exactly the way I like it.

Much appreciated again!

When I try to get data from Discogs using the pone mod I get this message in the last days:

401: Unauthorized

Any solution?

Have a look at this thread: /t/17761/1

THX!

I do wonder about one thing, mp3taglover. Could your script get YEAR from master release while everything else from actual release? Small thing that I can easily enter myself, but hey, if it can be done, why not?

I never get master release from discogs. You can parse from json master_url and get json from it and parse again "year" from it to embed.

I'm sorry but you will have to do this yourself.

Florian replied in another topic on this bug:

[F] Discogs - Error >> 401 : UNAUTHORIZED

EDIT:
and the solution is there as well at post #7
[F] Discogs - Error >> 401 : UNAUTHORIZED

Hi,

It seams that importing tags from Discogs is broken. I am not getting track names, artist year etc as you can see in the picture. I tried to look for release by id.

Release id 562191

Picture is attached

I also get 401 error in some cases even if I change all mta Discog Pone files by replacing http to https.


It works just fine.

  1. Update your mp3tag
  2. Change http:// to https:// everywhere in the script
  3. Re-login with your account on discogs with a browser (mp3tag will redirect you to that page) and allow mp3tag to use discogs API.

Perhaps it's just me, but since discogs went all HTTPS, it's been really slow.

It's working, because I did the updates, but the speed has become positively glacial.

Is it just me, or is this something others have found as well?

Once I deleted the cover read script it's been flying, its useless to me as I edit all my cover art.

I'm sorry - how do you do no.2 on this list?

Close MP3tag
Search the location of the script on the mass storage.
Open it with a plain text editor like the Windows Editor.
Use the search/replace function of the editor.
Save the modified file
Start MP3tag.

Perfect - thank you

Concur on this - once I knew how to edit the script, it breezed through at the old speed. For some reason the cover script had been uploading a blank file anyway, so not having this is better from my point of view

Not working. Every occurrence of http replaced with https. Logged of, logged on on website. Haven't seen any request from MP3TAG for a token or so. OAuth error. Discarding my current mp3tag.cfg is out of question.

Any ideas?

Every time I switch ip or reboot my PC I have the re-authenticate with Discogs now, is there anyway around this or is it the new normal? It's pretty annoying.