[WS] Google Images Cover Search

Hi

this is also a nice script.
Think you're mr. nice script maker right?

ok
Another question i want to Search for Artist + Titel so what i have to change?
Because i have many digitalisied Vinyls and so on many different Songs (Albums/Vinyls) from
1 Artist so i have to search for Artist & Titel.

thx 4 help

  1. open the script with a text editior (e.g. notepad.exe or wordpad.exe).

  2. go to the line:
    [SearchBy]=$replace(%album%+$if2(%albumartist%,%artist%),&,+,#,+,?,+,=,+,%,+)

  3. in this line, replace %album% with %title%

Updated to 1.4

Fixed: Script did not work after changes at google.de/images

Fixed: Picture URLs with a ";" in it did not work

Update 1.5:

FIXED:
Google introduced a new layout at images search. That stopped the script from working. Now it works again.

NEW:
I introduced two new columns at the "List of search results..." window:
"description" gives you an text extract form the page where the picture is from
"page" gives you the URL of the page where the picture is from

CHANGED:
The old script was made for google.de/images, this version is now for google.com/images. You can change that by simply changing the [IndexUrl]=.. line. I guess you can also put in other country domain ending to get country-specific search results. Just test it!

CHANGED:
I rearranged the different columns in at the "List of search results..." window.

CHANGED:
The "website" column comes now without leading "www."

  • see starting post for download -

Hi !

Do you plan to do the same plug-in for www.discogs.com?

You can already do this with my discogs script.
/t/9226/1

Set all "DISCOGS..." fields to "no"
Set "DISCOGS~TRACK_OPTION: LEAVE TRACK EMPTY?" to "yes"

Then the only thing which will be stored is the artwork.

1.5 stop working for me now

Hi,

1.5 stop working for me too.

updated to 1.6

skript's working again :smiley:

thanks for quick update pone!
you only change google.com to google.de?

no, that was unintentional. will set it back to .com right now.

i also left my personal customisation in the script, i will leave that, can be changed as described in the starting post.

what i changed to fix the script is in line 55 and 56.

had to be changed into

How Can I modify it for advance search in one site?

Use the google operator site:
http://support.google.com/websearch/bin/an...p;answer=136861

You can use the operator in the search box, or you can modify the script to always search only in one site. For example, search only at amzon.com:

[IndexUrl]=http://www.google.com/images?q=%s+site:amazon.com

However, some test I made with this didn't always bring me the results I hoped for. I don't know why.

Thank you very much for the update Pone :w00t:

Thank you very much! it is a great work! :laughing:

thanks pone,

1.6 works great. :w00t:

greetz

apollo10

Hi,

Today, the 1.6 script does not work anymore . I applied the inverse manipulation and everything works fine :smiley: .

In line 55 and 56.

had to be changed into

Bye.

[ggle trad]

Ditto here, works perfectly again now... :music:

Update 1.7

Fixed: Script stopped working. adapeted script to changes at google. now working again. Thank you biboun for your advice.

google image search 1.7 seems different like before:

how can i delete the column "description"
or has google changed something ...

greetz

apollo10