[X] Cannot add FLAC album art

I'm using the latest version of Mp3tag (2.65a) and I'm using Windows 8.1 64-bit.
I'm having an issue with adding album art to FLAC files. Attempting to do so causes a "File cannot be opened for writing" error and fails to save the art.
In addition, this makes the file unreadable and creates a backup file. I can change non-album art tags with no problems, and I've had no problems with saving album art on .mp3 files.
Any help here would be appreciated, and please let me know if any more information is needed. I've enclosed the error message that appears when I attempt to save album art.

hmmm, sounds like a file permission issue. Is the drive an internal drive on your win8 machine or an external USB or network drive? I have no issues adding arwork on my flac files so something is odd here.

It's an internal drive.

what steps are you using to add the art?

I select the flac files in the programme, then drag the album art file into the box on the left panel and save. I also tried right-clicking the box and clicking "Add cover..." but neither way works.
In the meantime your previous post inspired me to try moving the files to a usb drive before attempting it - and it works.
This must be a file permissions issue, as you said.

good that you found a way for it to work. But odd. Typically internal drives don't have the permission issues that external drives or network drives have. Maybe someone else can chime in with a suggested solution.

This depends on the history of the folder. E.g. if you have used that folder with XP before, then it may be that the permissions are not right.
You may check this in Windows Explorer e.g. with adding another column to the list display that shows the owner. If that column shows a strange arrangement of numbers and letters that does not match any of the user-ids on the PC then you should claim ownership of the folders and files.
WIndows has the sufficient means for that.
Here is an explanation on the WIndows support pages:
It claims to be for XP but the means are still the same for W7 and W8 (and Vista)

It looks like I am also having this same issue, but it seems to extend to ANY operation that involves an external file.

As example, I have a script that saves the content of the .CUE and .LOG files into a tag, which fails exactly as described.

It is most definitely a permission issue, because after running into the problem, I can't even delete the folder with the "offended" files: I get a "folder access denied" and asks me to provide administrator permissions, and then complains that it wants the permission of the user I am actually using (which is also the owner of the folder and the containing files).

If I wait for few minutes without doing anything, then the folder seems to return "normal" and I can delete it with no question asked.

I am also using Windows 8.1 64bit, with the latest mp3tag version.

I also tried to kill Windows Explorer and do everything from within Mp3Tag (to avoid possible conflicts with Windows Explorer) but with no luck. It fails exactly in the same way.

My guess is that this issue is not directly related to mp3tag, but maybe an update of Windows broke something Mp3Tag was using?

I doubt that you can really kill the Explorer as this would mean that you restart the desktop and stuff.

Anyway: the WE trys to update the file thumbs.db after you have changed something in a folder. You can avoid that with the folder option "Always show icons instead of file symbols" (my translation).
Perhaps switching off this (nicer) view helps to access the external folder.
Also, you shouldn't run WMP at the same time (which you probably didn't anyway).

Windows attempt to get an Administrator's access is the clueless response to the fact that it cannot execute the requested function - which in this case does not originate in insufficient access rights but that some Windows process tries to update the thumbs.db file.

I did actually kill explorer (or at least, what you can kill from the task manager). Indeed, I was operating without the desktop, to prevent any possible interference.

The thumbnails are already deactivated since long time, WMP is not running and neither are other programs that may be working on the files.

Apparently, the first time I try to add an album art, the process works just fine, but then the folder gets locked (impossible to delete and requesting admin privileges). If I then try to do some other operation involving external files, it fails.

EDIT: The issue seems to only happen if the files that I am trying to edit are inside my "User" folder. (C:\Users\MyUser). If I move the files to C: (root folder), or to another hard drive, the problem doesn't seem to happen.
So far, this works quite well as workaround.
Any more idea on why this happens?

If I move the files to C:

You could check if you are actually the owner of the folders and files. You can check that in WIndows Explorer if you activate a column for "Owner".
Because if you create new folders, you are the owner of that folder.
If you migrated from XP to a more recent windows version, it could very well be that the access rights did not come along.

Yet, if you experience the locking of the folder then it is still probably the indexer and the thumbs.db thing.

I don't know if this will help anyone, but I had the same issue after ripping my audio files with Exact Audio Copy. The option I chose to rip was WAV (uncompressed). I assumed that was the FLAC codec, which was what I wanted. I was getting the same error message when I tried to edit the tags on the files. I assume the problem was the output was a WAV file which does not accommodate tags.

I ripped the CD with EAC using the CMP option (compressed) which produced FLAC files includeing tags. No errors with MP3tag after that.

Yes, WAV (uncompressed) is not FLAC. And mp3tag doesn't work with WAV files.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.