[X] Cannot load subdirectoriy files on Mac

I am using mp3tag with wine on my Mac mini and iMac. All of a sudden I cannot load the files in the subdirectories of a directory which once was fully loaded seamlessly. mp3tag loads other similar directories seamlessly but not this particular one. All folder permissions etc are the same. I even copied this folder to a new one on the same disk but no way. I even copied whole disk to a new one. Still the same. I uninstalled and reinstalled mp3tag. I am stuck. This happens both on Mac mini and iMac. Any suggestions will be appreciated. Thanks

I don't have a mac.
If the MP3tg function to read folders and subfolders works in general but not for this folder, I would check what the difference is in respect to other folders.
A neat trap is also an unnoticed filter which leads to loaded but not displayed files.
An easy test would be to toggle the filter with F3 and see if the files are shown when the filter is off.

Thanks for suggestion.
I did it already both on mp3tag and on Mac. There is no visible dlfference with other folders. There should be something but I cannot figure it out. I even copied 3 subfolders to a new folder but again somehow mp3tag doesn’t like these :slight_smile: It doesn’t load these.

A folder is only shown if it contains files that are supported by MP3tag.
What was the result of the filter toggle?

No filters. This directory contains
Artist
Album
directories which include only mp3 files as with the other dir ctories which loads easily to mp3tag.

Can you go to this directory in Terminal.app and list its contents recursively using

ls -Rla

Alternatively, you can use Finder in list view and expand all the folders and make a screenshot using CMD + Shift + 3.

I did it. This is a folder with with 1026 subfolders. When I drag acnd drop the folders only folders name appears in mp3tag but when I do the same to the mp3 files then they appear.

Any difference if you load the folder via Ctrl + D instead of drag and drop?

Unfortunately not. It doesn't load this folder.

I solved it!!
It is because of too many subfolders. On all other folders there are one less subfolder and mp3tagg can load them. There must be one less folder!!

Thanks everybody for your concern about my problem. I really appreciate your help and interest.

Happy tagging!

Is this a Mac limitation? How many subfolders were there? How many subfolders can one load without problems?
I have several folders with more than 10,000 subfolders each but no problems to load them.

No it is not a Mac problem as I can reach these files with any Mac app. There is actually 2 subfolders but mp3tag reaches my harddrive through wine and it sees my hard drive as a folder and there seems 5 subfolders (look at the last pic that I shared). It could be a limitation of wine. If there are 4 (actually 1 subfolder) mp3tag loads the files.
There could be a warning pop-up window by mp3tag. I wouldn’t spent my two days.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.