[X] cannot work under vista


#1

hello :slight_smile:

i use the 2.35o under xp and it work great - now as tester from visa i tried to run it again. i only got the message that there is not enough memory if i want to add my folder with 180 files. hmm there was a crash too but i was too fast and dont know yet where tof find the log file for u. :ph34r:


VISTA Public BETA 2 !! Fehler --->
#2

Vista is still beta and has a lot of bugs. I'll look into it when it's released and I got a license for it.

Regards,
Florian


#3

I am not sure if the problem isn't caused by the ListView since my Amazon Cover Downloader also crashes and an empty project with only ListView, too. No problems when creating a VB .NET, C++ .NET or C# project with a ListView, though.

Edit: Florian, I recommend throwing an error in the setup if the detected Windows version has the number 6.0 (if that is possible with NSIS, but I think it is).


#4

The "not enough memory" message comes from one of the low level memory management classes which are throwing std::bad_alloc in Vista (for no obvious reasons).

Good idea! I'm already doing this with the W9x/ME operating systems.

Best regards,
Florian


#5

I am also seeing this problem (not enough memory to complete the operation) on the latest Vista Beta 2 build. The repro steps are rather simple: Open Mp3Tag, click on the Tools menu. Or load a directory of any size.

The error log generated by Mp3Tag reveals:

=======================================================================
=========
Mp3tag v2.36a - 21.06.2006 - 22:44:47
--------------------------------------------------------------------------------
OS-Version: Unbekannte Windows-Version
--------------------------------------------------------------------------------
Build: Jun  3 2006 17:45:34
--------------------------------------------------------------------------------
AppPath:  70.915.964.928 Bytes frei (C:\Program Files\Mp3tag\)
DataPath: 70.915.964.928 Bytes frei (C:\Users\Navid\AppData\Roaming\Mp3tag\data\)
TempPath: 70.915.964.928 Bytes frei (C:\Users\Navid\AppData\Local\Temp\Mp3tag v2.36a\)
================================================================================

--------------------------------------------------------------------------------
THROW
--------------------------------------------------------------------------------
File:		.\sprogresswnd.cpp
Line:		504
--------------------------------------------------------------------------------
CATCH
--------------------------------------------------------------------------------
File:		.\mtfileview.cpp
Line:		589
================================================================================

I tried a number of different methods to workaround the issue but all to no avail. I've been using Mp3Tag on XP and 2003 for many years without incident.

I really hope this gets fixed soon because Vista BETA2 is of exceptional quality, and I could never go back :slight_smile:

Thanks,
Navid


#6

Yup, probably to the next release :slight_smile:


#7

Thanks. I have to be honest -- I was getting desperate and even tried Tag&Rename. But it does not even come close to the ease of use of Mp3Tag. I uninstalled it promptly. And now, for the first time since I have got Mp3Tag, I've created an 'Untagged' folder... I'm anxiously awaiting the next release, then.

I'm more than willing to regress the bugfix on Vista Beta2, if you like. I'll keep an eye on the development release.

Thanks again,
Navid


#8

Hi there,

I too am using Vista (Build 5456) and have just discovered that mp3tag doesn't work. I spent all day yesterday trying different tag editors and it has given me a new found respect for your app. It seems there truely is nothing else out there with the same features. I hope you can get it to work with Vista as I feel like I've lost an arm or something :slight_smile:

Thanks for all your work on this great program.


#9

Hope it works now :slight_smile:


[X] Crash On Vista
Windows Vista
#10

:smiley: :smiley: :smiley: Just installed and on initial inspection it looks like that worked. THANK YOU!!!