[X] Can't save LYRICS metadata field into ALAC(m4a) files

In v2.78 I tried to save LYRICS(synced lyrics) field into ALAC encoded files, but when I reopened the 'Extented Fields' dialog I found the tag name become 'UNSYNCEDLYRICS'.

I used another file whose UNSYNCEDLYRICS field was already present and tried to write the LYRICS field into it. Then there was two UNSYNCEDLYRICS fields.

This issue is 100% reproducible on my Windows 10 Pro x64 (Simplified Chinese) computer with v2.78 and the latest development version v2.80c.

I wonder whether it's a bug or a feature...I know that iOS devices don't support synced lyrics, but I still want other music players to work with it...I apologize for my broken English.

See this thread on the field SYLT:
/t/5707/1

also check if you have some kind of mapping in your settings that saves SYLT to UNSYNCEDLYRICS.

Thank you for your reply. :laughing:
I checked Options-Tags-Mapping, and there isn't any mapping related to SYLT/UNSYNCEDLYRICS/LYRICS.
In addition, SYLT in ALAC is not mapped to UNSYNCEDLYRICS(but I need LYRICS). And LYRICS field works with MP3 format.

See the table of supported fields and their appearance in different tags:
http://help.mp3tag.de/main_tags.html

Please note that the SYLT field is not supported by MP3tag and neither is the LYRICS V1 tag that is part of the Id3V1 standard.

I think ALAC uses its own tag format, but not ID3.
I try to add a field named FOOBAR and this non-official field still exists when I open the file again.
Can this unexpected mapping ('LYRICS'->'UNSYNCEDLYRICS') be optional?

See this Wikipedia link on ALAC: https://en.wikipedia.org/wiki/Apple_Lossless
Again: if you tag mp4 files with the field LYRICS then this is equal to UNSYNCEDLYRICS in MP3s.
See the field mapping in the help for this: http://help.mp3tag.de/main_tags.html

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.