[X] Context Menu in WinNC doesn't work anymore since v2.51

Hi Florian,

first and foremost: great work, thank you so much for this great program! It's reallllly about time to donate or check out your Amazon wish list.

I checked the FAQ and the forums as deeply as possible but I reckon this one isn't documented yet. Since my update to MP3TAG 2.51 I have the following problem:

  • I run Windows 7 Ultimate, 32 bit, Service Pack 1.
  • Instead of the Windows Explorer I use WinNC 5.7.00 as a file organizer (winnc.net), the followup of the good ole Norton Commander.
  • With the update from MP3Tag 2.50 to 2.51 I lost the ability to use the "right click" context menu in WinNC to start MP3TAG within my chosen music folder (either marking the album folder itself or marking the files within). The context menu program start works fine in Windows Explorer, but that program is a pain in the neck.
  • Mp3TAG still shows up in the "right click" context menu of WinNC, but it doesn't do a thing if I click it.

I hope that describes it necessarily, if you have questions, please ask. I try to be more specific where necessary. Could you give me a heads up if this problem will be tackled and about when that might happen? Just one question: Do you still keep a Mp3TAG 2.50 version on your server and if, where would I find this?

Thanks so much, kind regards

Did you install MP3tag 2.51 in a different directory than V2.50?
Does WinNC automatically import the Explorer settings or does it have to be forced e.g. with a new installation to re-read the Explorer configuration?
Did you install MP3tag with other access permissions than you use it?

Hi ohrenkino,

  • V2.51 was automatically installed through the update shell in V2.50, as far as I could see it was in the same directory C:\Program Files\Mp3tag.
  • WinNC does indeed use the same settings as the Windows Explorer.
  • Since the install went via the automatic update checker, I can't guarantee that it was installed "as administrator" what I usually prefer.
  • I have uninstalled Mp3tag and reinstalled it as admin from my HDD, but to no avail. It still doesn't work... thanks for your help and patience.

There is a German thread that in the end has a registry download to patch the context menu entries.
The phenomenon is similar: after update the context menu entry is still there but nothing happens.
[X] Shell-Erweiterung in Win 7 64-bit
and have a look at post #12.
The txt-file has to be renamed to .reg to get imported into the registry.

Hi and thanks, ohrenkino.

I uninstalled / reinstalled WinNC 5 accordingly and renamed the reg file before importing it into my registry. Unfortunately that didn't solve the problem at all.

  • The only effect is that Mp3Tag now doesn't show up anymore in the context menu of WinNC 5 at all.
  • The reg file screwed up the functionality in Windows Explorer as well. When I roght click on "Open in Mp3Tag", I get the prompt "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."
  • I use a 32-bit version of Windows 7 Ultimate instead of a 64-bit version (which was the above mentioned German thread about).

So far this made it worse.

After this experience I kicked out the reg entry, uninstalled Mp3Tag V2.51 and reinstalled Mp3Tag V2.48. Still the right click context menu is the same as described above.

Hmm, I am pretty clueless what to do now. Any ideas?

Sorry for bothering you guys so much, but here is some additional info - mybe it's helpful:

  • After cleaning my machine of all Mp3Tag versions and related registry entries, I reinstalled Mp3tag 2.48 which I still had on my HDD.
  • Starting V 2.48 though the right click context menu works properly in Windows Explorer.
  • Starting V 2.48 though the right click context menu works properly in an older WinNC version - which can't handle huge HDDs though (2 TB).
  • Starting V 2.48 works not anymore in WinNC 5 (which can handle huge HDDs). This is peculiar because it worked like a breeze before I installed V 2.51 the first time.

I noticed that

  • The registry fix by the German user showed up in the right vclick context menu as "Open in Mp3Tag", while the original entry set by Mp3Tag V2.48 just reads "mp3Tag". IMHO that shouldn't make a big difference though - as long as the correct orders are given.

To reiterate: It would be totally cool if I could start V 2.51 per right click again. Thanks and have a good night!


unfortunately I still couldn't resolve this problem. I tried uninstalling and reinstalling WinNC and Mp3Tag v.2.51 as admin, with a system reboot in between all steps.

Alas, the right click context menu to open Mp3Tag in WinNC doesn't work. What can I do? Any ideas anybody? The abovementioned method fixing the reg entries was not successful either.

I this now officially a bug which might get addressed in an updated version of Mp3Tag?

Any help would greatly appreciated. Thank you!

Because simply ~95% of all Windows 7 issues seem to be UAC related, I am guessing that the likely cause is that you are running both applications with different elevated privileges.
What does WinNC support say?


I'm using FreeCommander and noticed the same issue.
On the FreeCommander webpage, I found this text :

New: 64 bit context menu will be showed on Windows 64 (XP, Vista, 7)
You can now control 64 bit context menu with the following line in the freecommander.ini:

- You can call 64 bit context menu with right click
- For calling 32 bit context menu use LeftWin+RightClick
- If you prefer to see for right click always 32 bit context menu: define ShowContextMenu64Bit=0; with LeftWin+RightClick you can call then 64 bit context menu

I tried what they said with the LeftWin + RightClick and I noticed that MP3Tag started as it was before... thus working great :wink:
I have a 64 bits Win7 version
From this behaviour, I understand that context menus for 32bits or 64bits applications are different.
They are probably stored in the registry somewhere.
I did a lookup in the registry and found a different uid numbers for what seems the context menu...
Maybe the developers changed an uid for the application mp3tag and forgot to change that number for all platforms ? (32/64 bits)

This will probably not help basic users but maybe someone more advanced in Windows could help with that...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.