[X] Date tag saved as a year tag


#1

Using 2.81a

Trying to add a date to a MP4 video file and when i save the file and check the tags its been saved as a Year tag as the file now has two year tags.

This is consistent across different machines and installs of MP3Tag


#2

2 things:
Merging YEAR and DATE has happened here:

[2013-10-06] CHG: reverted change: ID3v2.3 TYER/TDAT now merged into one YEAR field formatted as YYYY-MM-DD (due to popular request).
(see the changelog for that: http://www.mp3tag.de/en/changelog.html)

And also see the supported fields: http://help.mp3tag.de/main_tags.html

If you want to save an accurate data, use RELEASETIME
(where there is no DATE field).


#3

so why would i get two YEAR fields in the MP4 file?
and if the date field is not “supported” why is it shown?

thanks for the info


#4

You have to do some investigations.

Make sure that there is one column defined in Mp3tag column view:
Name : TagRead (TagTypes)
Value: %_tag_read%[’ (’%_tag%’)’]

Regarding MP4 file, this column should display the text ‘MP4 (MP4)’.

Read about “user defined mappings” in “Mp3tag help manual/options/tags/mapping”,
and check, …
if there is an additional mapping defined, …
within the Mp3tag dialog “Options/Tags/Mapping”, …
which affects the tagfield YEAR.

Note: In “Extended Tags …” view there is no problem to add multiple YEAR tagfields into the MP4 tag, just by adding so much tagfields with the name YEAR as you want.

Also there is the possibility to create multiple YEAR tagfields, when entering a string of e. g. ‘2015\2016\2017\2017\2017’, which will create five tagfields with the name YEAR.

Because of the internal mapping from DATE to YEAR any newly added tagfield DATE will be mapped and added to the multiple YEAR taglist.

You can avoid this behaviour by using the action “Format value” or the Converter “Tag-Tag”:
Field: YEAR
Formatstring: ‘2017\’

This will create one single value tagfield.

DD.20170321.1851.CET


#5

If you enter DATE, it currently automatically gets remapped to YEAR for MP4 (which is then internally an ©day MP4 atom). So if you write YEAR and DATE, you’ll end up with two YEAR fields.

That’s a really good question – I’ll remove it from the list.

Kind regards
– Florian