[X] Disappearing Tags Using Ctl+S on multiple mp3's

I'm still on 2.6.6, so sorry if this has already been fixed.
Load up the two files below, select and Ctl+S (Save tags), and many of the tag entries disappear.
I wonder how many times I've done this. Ouch!

rko

1.mp3 (2.94 KB)

2.mp3 (2.94 KB)

Please explain why your download files offered as "QuickTime Control Object" ???

Regarding your problem ... check the Mp3tag options for reading and writing Tags.

DD.20150725.0850.CEST


As to QuickTime I don't know. I just grabbed a couple of random podcasts and cut them down to size using mp3directcut (so they could be uploaded under the Max file size limitations of this forum). Attached are a couple of other random podcasts. Open these in Mp3tag, select them, press Ctl+S (Save Tag) and watch many of the tags disappear.

Attached also is a screenshot of my mp3tag options dialog box for tags. Nothing unusual as far as I can see.

Thx for your attention.

rko


a.mp3 (29.7 KB)

b.mp3 (19.9 KB)

Hmm, seems to be a problem within my system, I have to do a closer look.

This scrrenshot is not helpful, please show us the following dialog window with the Mpeg setup.

DD.20150725.1342.CEST

attached.
rko


Your picture and the settings in Mp3tag Options/Mpeg are looking ok for me.

If after execution of an action, which has modified the filename or the filepath, ...
one or more data rows disappear from the Mp3tag listview, ...
then the regarding file might have been moved to a different location.

Also it could be, that the file has been just accessed and blocked by another application, ...
which runs in the background and watches for changes on files or directory, ...
with the effect of blocking reading access for Mp3tag.

Once you scroll the line cursor bar over those tracks, the current data may appear again.
Refreshing the view by "Mp3tag/View/Refresh [F5]" can help to detect, which files have left the current view.

DD.20150725.2026.CEST

nah ... still on the desktop

nah ... very simple operation, and i can open the file with notepad++ and see that TIT2 has been erased.

either looks like a (very serious) bug to me, or something unusual in the setup of my rather simply configured win/xp laptop.

rko

just to be clear this is only an issue when you select both (2) mp3's. ctl+s does not erase the tags for single mp3's.

rko

MP3tag and Windows Media Player do not go together well if they are open at the same time.
Esp. with external drives, where writing takes a little longer, you see empty fields in the list view after saving.
You then have to either refresh the files manually (scroll with the cursors through the list) or close WMP while editing.
If you manipulate the allegedly empty files again, then they loose the contents of their tags. You have to refresh them first.
Yet, it could be that it has nothing to do with the behaviour on your system. Yet, it seems to be a local configuration that causes the problems.

  • I don't use windows media player and no program (except mp3tag) was open when the disappearing act occured.
  • not using an external drive
  • refreshing doesn't help
  • it's only a few (key) tags that get wiped out, not all of them
  • it only happens when you do Ctl+s with multiple files. Ctl+s works fine with only 1 mp3

thanks though for giving this some thought.

rko

I cannot reproduce this behaviour.

Some developers will ignore bug reports from a user who is not using the latest version.
I suggest updating to ver 2.71. and see if the problem remains.

Do have a look into the process list of the Windows Task-Manager.
There are many other programs, which share the processors runtime.
Maybe there is a resident virus watcher or some other crawler application, ...
which have access to the media file in the moment, ...
when Mp3tag just has made a change or wants to make a change to the file.

DD.20150727.0822.CEST

Are you unable to replicate the problem? Remember it only happens when there are two mp3's.

Attached are screen prints of TaskManager. In case you're not familiar with some of the items:
GBPoll is part of the GoBack system (recovery manager), which is not installed
Cepstral is text-2-voice (this is just the license verification task should i use the app)
k9filter is the BlueCoat proxie
... and there's AVG antivirus

Pretty basic setup, and yet the problem persists. (and happens on both the c: drive or any USB-attached drive).

rko



Just a shoot into the dark ... pay attention to ...
Cepstral, GBPoll, SMAgent, locator.exe, k9filter
Make sure that the shortcut [Ctrl+S] has not a second global assignment.

DD.20150727.1409.CEST

Are you unable to replicate the bug?

Indeed.
The only conditions that remotely resemble that what you have described have been described before.
In the case that I can reproduce on just one system that seems to have problems with the USB3.0 driver, the Windows Media Player is mandatory.

I tried your files, selected one, then two than more and never did I get any erased fields.
So: sorry. I cannot help.

i upgraded to the latest version of mp3tag ... still a bug
i tried the test in windows xp safe mode ... still a bug

hum?

rko

I tested your files again and I can read and write just as expected. e.g. I added the ALBUMARTIST for both files. And now both files have the same ALBUMARTIST and the other data is kept.
As other users have reported that they cannot reproduce the error, it is doubtful that this is really an MP3tag bug but the suspicion is that some kind of local setup interferes.

Regarding the "hum?": I cannot look over your shoulder and see what is strange.
I would check the system: run a chkdsk /v /r on the drive and see if any errors pop up.
Then I would have a look at the S.M.A.R.T parameters of the HDD and see if the drive has too many hovering sectors or something like that.
Then I would run MP3val and MP3diags to see if any strange tags are in the files.

Thanks for your attention to this "bug" to-date. I guess it's going to be one of those where I eventually get an 'ah ha' moment.
It's curious that it doesn't happen with a single podcast.
I'm guessing it's related to my previously reported issue with dbPoweramp:
/t/17085/1

I'll get around to deleting that program to see if it helps. When I find out I'll report back for future reference.

rko

Fixed.

I deleted Mp3tag completely, including all mp3tag entries in the registry, then I did a full reboot of Windows and reinstalled the latest version of Mp3tag. That worked.

Thanks for your attention.

rko