[X] File and Folder names on Wine32

I run mp3tag on wine on Linux. I expect that's not supported, but I'll report my issues anyways since I've never had a problem with mp3tag on wine and this did not happen before v2.60. In fact mp3tag has never crashed under wine for me until 2.60

  1. Filenames with a "?" in them would refuse to load in mp3tag. Once I removed the "?", the tag would be read by mp3tag

  2. Folders with a "." in the name will not read. Likely related to bug #1. Nothing happens when I try to load the folder (eg "L.S.U.")

The question mark is an illegal character for DOS filesnames - amazing that WINE does not have a validation mechanism.

ad 2: Folder names with a dot to not cause any trouble in WIndows. Perhaps you have an active filter so that it only looks as though no file is loaded. Check the status bar how many files got loaded and how many are displayed.
Or if this is not true, it may be due to the WINE environment.

That's interesting. A question mark has never caused a problem in mp3tag before. Nevertheless, I have an action to run after renaming that removes DOS illegal characters.

There was no filter active. Here's my steps:

  1. Click "change directory" icon
  2. Browse and select the folder with dots in them (eg. L.S.U.)
  3. Click OK ==> Folder selection window closes with no change in the program
  4. Rename folder in a file browser to remove dots (eg. "LSU")
  5. Repeat steps 1-3 ==> Folder now becomes active in the program

It's always possible that the problem is with WINE.

You cannot create a folder in windows with a dot as the last character.
Perhaps this is the cause. Make a test to name to name the folder "L.S.E".

You're right! Without the dot as the last character the folder will load.

Perhaps WINE is now better at emulating the Windows environment... I'm sure I've worked on that folder before with mp3tag.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.