[X] MP3Tag can't see the tags?


#1

I'm using MP3Tag 2.27a and Foobar2000 0.8.3 with ID3v2 plugin (WinXP Pro SP2). Here is my problem - after adding Replaygain info using FB2K, MP3Tag refuses to see most of the tags.

Here is the screenshot, which illustrates the problem: http://www.nncron.ru/temp/scrnsht.png .

There are two files: initial one ("INITIAL - 16 - Untitled (End).mp3") and one with Replaygain info added ("16 - Untitled (End).mp3"). MP3Tag can not see the tags, which are still there (I opened FB2K FileInfo panel and press 'Reload info from file' to be sure, that tags are not 'cached' somewhere).

I'm pretty sure there is something wrong there. Here are both files. Initial: http://www.nncron.ru/temp/INITIAL%20-%2016...led%20(End).mp3 and the one with Replaygain info: http://www.nncron.ru/temp/16%20-%20Untitled%20(End).mp3 . The each files is ~150K.

FB2K settings: Input - Standard Inputs - MP3 Tag writing: Id3v2 and Id3v1.
MP3Tag settings: Tags - Mpeg - Read: ID3v1, ID3v2, APE

It is interesting, that if I change the last settings to 'Read: ID3v1', the tags will appear again...

Do you understand - what is wrong?

Thank you.

--
CU
VK



[X] Tags Disappear (ID3)
#2

Hello.
Mp3tag can't read tags in UTF-16 (Unicode) format, please go in the options of the foobar id3v2 plugin and select "Always write ISO-8859-1 tags instead of UTF-16" if you want Mp3tag to read the tags.


#3

Hmmm... So why it reads the tags if I set 'Read: ID3v1' in MP3Tag options? (I'll try your suggestion ASAP).


#4

Mp3tag always displays only one tag. So if you have set read to id3v2 and id3v2 and a id3v2 and id3v1 is present, it will try to display the id3v2.
So if you select to only read id3v1, it will show you only the id3v1 which is no problem.


#5

2 Dano:

thank you for your suggestion. Setting FB2K to write tags in ISO-8859-1 solved the problem.

Just curious: when ID3V2 tags were saved in UTF-16, there was still one field, which was dispalyed correctly by MP3Tag: the Year field. Why this happens? Is the 'Year' the only Unicode-aware field? :slight_smile:


#6

As the year field is only designed to support numeric values, it is written as ASCII text.


#7

This suggestion worked for me. At first I thought it was a bug in 2.27c, because I hadn't run across this behavior with any other version. Then I remembered I'd recently upgraded to a newer version of the foobar ID3V2 plug-in; it must've reset that option.