[X] MP3TAG hangs if external drive not connected


#1

Not sure if this is a bug, but it happened to me.

I was using Mp3tag to edit some files on an external drive connected via USB.

Later, I invoked Mp3Tag again, but this time the external drive was not connected. The program just hung.. presumeably looking for the last set of files it had loaded from the external drive, which of course was not connected anymore. There was nothing I could do to interrupt it, stop it, cancel it, except use CTL+ALT+DEL to kill the process.

The only way I could get MP3Tag running again, was to reconnect the external drive again.

I am using v2.37d with windows XP Pro.

Thanks


#2

MP3 tag does try to go back to the last directory it was reading. I have not tried anything external, but when the directory is was pointing at deletes, it goes back to it's install directory.


#3

I've just tried to reproduce it with the latest Development Build and can't reproduce the problem. As Mark has stated above, Mp3tag changes to its program directory when the last active directory is not available any more.

Kind regards,
Florian