[X] MP3TAG Importing M3U files is dropping tracks


#1

I've been using MP3Tag for about a year with great success.

About 2 weeks ago a problem came up. I upgraded to the latest version of MP3Tag (v2.69) about the time the error began.

I use MP3Tag to import M3U playlists. Up until a few weeks ago, this worked without any problems.

I just noticed that MP3TAG while imported M3U playlists is dropping some tracks. Meaning that the track is in the M3U playlist file, but when importing into MP3TAG, a track is dropped.

I create my M3U files via FOOBAR2000 (v1.3.1), When inspecting the M3U file in a text editor, it looks fine.

My M3U playlists are typically 30-40 tracks total.

What am I no doing wrong that is causing MP3TAG to drop tracks?

Thanks for any help you can provide,

Jerry


#2

Perhaps you have dropped tracks as duplicates in the playlist?
As MP3tag references the filename and the filename is unique, it is the Highlander principle: there can only be one.
Or the files do not exist at all.
Or you could have an active filter that hides certain files - press F3 to check that. You can also check the statusbar at the bottom to see how files got loaded and how many are actually displayed.


#3

Additionally to ohrenkino's advices you can check ...

  • Mp3tag Filter is active?
  • Mp3tag setting options ... "Tag" ... list of allowed incoming file types?
  • Mp3tag update to v2.69a?

DD.20150426.1923.CEST


#4

Thanks for your suggestions.

Here is what I have tested, and the problem has persisted.

  1. I have filters turned off - no change in importing.
  2. When loading, MP3TAG will show "Reading Tag Data 1 of 35" and continues to quickly count up as individual lines from the M3U file are loaded. But when the loading is done, maybe 1 or 2 tracks of the 35 are missing.
  3. I have tried both M3U and M3U8 files, same result
  4. The files for the tracks do exist. There is no issue with the files missing or having an incorrect path name.
  5. The problem also happens when I load older play lists that up until a few weeks ago, imported fine. This leads me to believe it might be a slight bug in v2.69.

I would appreciate if someone can create a small 30 or 40 track play list and see if the problem appears in your version of v2.69.

One more question, if I have an older version of MP3TAG - v2.54 - will there be any issues if I uninstall v2.69 and reinstall v2.54??

Thanks for your help,

Jerry


#5

I have not seen this behaviour, nor can I reproduce it, with any playlist I create using Winamp.
I am inclined to suspect your playlist, instead of Mp3tag.

Maybe the investigation will be helped by considering these questions:

  1. Is it always the same tracks that are missing?
  2. Are missing tracks located on anything but a mounted internal or external hard drive?
  3. Does the problem persist if you edit the playlist by copying the path from the file system (not Foobar)?

#6

You have to investigate which circumstances might be different for these missing files in relation to the other files.

Do all the playlist entries really point to one related existing file?
Are there any two playlist entries which points to the same physical file?
Let us see the playlist in question.

You can open the playlist file within a text editor.
Then load each filepath entry, step by step, separately from within Mp3tag and see what happens.

DD.20150427.1741.CEST


#7

I found the problem - I think.

The import doesn't allow multiple tracks of the same exact track.

I created a new playlist with 30 tracks all of the same song. MP3TAG will only import one of them, and ignore the other 29 instances.

This is a bug for my usage. Can anyone else verify my test of this?

Thanks,

Jerry


#8

Yeah, everybody. :wink:

Mp3tag writes to files, not to some text list or data base.
Every file is unique. There is only one instance of any file.

It would be pointless to show the same file more than once when editing its metadata.

Just for interest sake, what is your usage?


#9

It is not a bug, it is normal behaviour in MP3tag.
Also, see post #2 where this exact possibility was mentioned ("Highlander").

Also, I do not see a problem: Mp3tag is a tagging program. It is no player. Playlists are only relevant for players, I think.
If you only want to modify the tags, you are fine. This will be carried out in all the files of your playlist.
You do not have to create a new playlist as long as you leave the filenames untouched.
This will let you keep as many duplicates in your playlist as you like.


#10

Thanks for the notes.

I use MP3TAG to convert the M3U playlists to a CSV file for import into an excel spreadsheet.

I'm actually working on a PERL script to do a similar thing, and thus bypass MP3TAG for my usage.

If I can get past a small hurdle in PERL I should have a much more dynamic CSV converter for my usage.


#11

Thanks for everyones help. Got my Perl script to export the MP3 metadata to a CSV file. This will also give me more control into the future with my metadata manipulation.

Appreciate your help.


#12

Hi Everyone,

I think I noticed a bug.
I imported an m3u file (UTF-8) containing some unusual characters, and the program dropped the files containing those characters in their file names.
Characters: á é í ó ö ő ú ü ű ä ç ã

I tried what if I only import those files, and it imports them without any problem.

Can you please check this problem?
Thanks in advance!


#13

what happens if you rename the file extension to m3u8 to indicate that it is encoded in UTF-8? (if it is at all)


#14

Hello new user Mese, why did you hijack such old thread, are you afraid to open a new thread for your specific new problem?

Please check the situation again by using the test files from within the attached zip package.
TEST.M3U8.zip (2.04 KB)

DD.20171112.1959.CET

TEST.M3U8.zip (2.04 KB)


#15

No. :slight_smile: I was not afraid, just was thinking it is better to write to an existing topic if it already exists.

I tried the files you sent. The mp3s work like charm, but both the playlists get the same error message:
Test.m3u8.4_ä ç ~a.mp3 cannot be accessed.



#16

Which OS do you use?
(Because when I load the playlists, I see all the files and no error message - it is also strange that you get an error message only for one file and not all of them).


#17

I use Windows 10 Pro English variant with Hungarian keyboard layout.
Hungarian language includes all these characters: áéíóöőüűúű.
But it does not contain ä ç ~a letters, nor letters with ˇ^ (â ě) and so on.

I tend not to contain special characters in filenames, I just found it weird, that it works with the files, but not with the playlists.


#18

How far have you got with the research whether renaming playlists to .m3u8 (and not just m3u) helps.


#19

I used both the m3u and the m3u8 files you sent. The happening was the same.


#20

Simply renaming an existing playlist from *.m3u to *.m3u8 doesn't address the problem.

It seems that those special characters you were mentioning caused Mp3tag to drop the files from the playlist. Can you try to create a *.m3u8 playlist either from Mp3tag or foobar2000 (or your other software that supports *.m3u8)?

This way, a real UTF-8 encoded playlist is created and Mp3tag can correctly detect and decode the special characters.

Kind regards
— Florian