[X] No Tag Info Displayed...


#1

First off, Happy New Year to everyone !!

Hopefully this isn't something stupid that I'm missing/overlooking. I've got a sample file which doesn't show any tag info in MP3Tag (v2.34H). However, I can see tag info with other programs ( Winamp tag editor, dbPowerAmp Windows Shell extension, Hex Editor, etc).

So my question is, why does no tag info show in MP3Tag for this file ? I can believe that the tags may be malformed in some way.

I'm attaching the sample file.

Thanks,

John 

<OOPS. File is too large to attach. OK, I'll see if I can trim it down and keep the headers intact>

Don't know if I just paste in the header info. May just give you a headache....

00000000 4944 3303 0000 0000 1160 4D43 4449 0000 0040 0000 3500 2B00 3900 ID3......`MCDI...@..5.+.9.
0000001A 3600 2B00 3200 4100 3000 4500 2B00 3500 3900 3500 3400 2B00 4100 6.+.2.A.0.E.+.5.9.5.4.+.A.
00000034 3500 3100 3100 2B00 3500 3200 3100 4600 3700 2B00 3500 3200 3300 5.1.1.+.5.2.1.F.7.+.5.2.3.
0000004E 3200 3300 0000 5452 434B 0000 0002 0000 0032 5052 4956 0000 000E 2.3...TRCK.......2PRIV....
00000068 0000 5065 616B 5661 6C75 6500 FF7F 0000 5052 4956 0000 0011 0000 ..PeakValue.....PRIV......
00000082 4176 6572 6167 654C 6576 656C 00FD 0F00 0054 4C45 4E00 0000 0800 AverageLevel.....TLEN.....
0000009C 0000 3136 3133 3630 0054 5045 3100 0000 1000 0000 4172 6374 6963 ..161360.TPE1.......Arctic
000000B6 204D 6F6E 6B65 7973 0054 434F 4E00 0000 0700 0000 496E 6469 6500 Monkeys.TCON.......Indie.
000000D0 5449 5432 0000 0010 0000 0043 7572 7461 696E 7320 436C 6F73 6500 TIT2.......Curtains Close.
000000EA 5441 4C42 0000 0017 0000 0042 656E 6561 7468 2074 6865 2062 726F TALB.......Beneath the bro
00000104 6164 7761 6C6B 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 adwalk....................

<...music data here...>

00275502 2205 7EA9 1495 0D08 4150 4554 4147 4558 D007 0000 AE00 0000 0400 ".~.....APETAGEX..........
0027551C 0000 0000 00A0 0000 0000 0000 0000 0700 0000 0000 0000 4D50 3347 ......................MP3G
00275536 4149 4E5F 4D49 4E4D 4158 0031 3435 2C31 3931 0B00 0000 0000 0000 AIN_MINMAX.145,191........
00275550 4D50 3347 4149 4E5F 554E 444F 002D 3030 312C 2D30 3031 2C4E 0C00 MP3GAIN_UNDO.-001,-001,N..
0027556A 0000 0000 0000 5245 504C 4159 4741 494E 5F54 5241 434B 5F47 4149 ......REPLAYGAIN_TRACK_GAI
00275584 4E00 2D36 2E36 3235 3030 3020 6442 0800 0000 0000 0000 5245 504C N.-6.625000 dB........REPL
0027559E 4159 4741 494E 5F54 5241 434B 5F50 4541 4B00 312E 3237 3032 3539 AYGAIN_TRACK_PEAK.1.270259
002755B8 4150 4554 4147 4558 D007 0000 AE00 0000 0400 0000 0000 0080 0000 APETAGEX..................
002755D2 0000 0000 0000 5441 4754 7261 636B 2032 0000 0000 0000 0000 0000 ......TAGTrack 2..........
002755EC 0000 0000 0000 0000 0000 0000 0055 6E6B 6E6F 776E 2041 7274 6973 .............Unknown Artis
00275606 7400 0000 0000 0000 0000 0000 0000 0000 0055 6E6B 6E6F 776E 2041 t................Unknown A
00275620 6C62 756D 2028 3031 2F30 322F 3230 3035 2030 303A 3000 0000 0020 lbum (01/02/2005 00:0....
0027563A 2020 2020 2020 2020 2020 2020 2020 2020 2020 2020 2020 2020 2020
00275654 2000 020C ...


#2

Happy New Year :slight_smile:

Just send me the file to my contact email address.

Best regards,
~ Florian


#3

So far, no luck trimming a test file.

I tried trimming a file using Audacity. But it ends up "re-writing" the ID3 headers. And then MP3Tag can see them just fine.

One thing to note is that Audacity ignores/drops the APE header. So I don't know if that plays a part in MP3Tag not seeing the original tags (ie. having ID3v1, ID3v2 and APE tags).

Sorry to be so vague with this problem report.

John

P.S. Just saw your reply about sending directly to your email address. Will do. Thanks!!


#4

Good point, because Mp3tag displays the tags in this priority: ID3v1 < ID3v2 < APEv2.

Maybe the file has an (almost) empty APEv2 tag (it can get one through MP3Gain). Just disable reading of APEv2 tags at Options > Tags > Mpeg for testing.

Best regards,
~ Florian


#5

The file you've provided has an almost empty APEv2 tag. Just disable APEv2 reading if you don't use it.

This topic has been marked as "No bug".

Best regards,
~ Florian


#6

Yup, turning off the APE Read option fixed the problem for these files. Thanks. It's very useful knowing the "precedence" of the tag; and more importantly that multiple tags are not "merged" when read in.

Thanks again for the quick reply -- not to mention a wonderful product.

 Sincerely,
 John