[X] Possible ID3v2.3 (UTF-16) issue


#1

(First off, forgive me if this isn't actually a bug.)

Over the last month or so, I have decided to try out some different software, the programs pertaining to Tagging of course. I have been using MediaMonkey as my Player & main tagger since the middle to later part of 2006, and recently I have brought in MP3Tag to aid in tagging certain things and such.

Anyway, one of the programs I ran across was titled 'MP3AllFramesTagger' which will show you all the frames stored in an MP3 (including those annoying "PRIV" ones left from WMP, but that's not the point) and I noticed that often times, the values for the frames would be simply 3 characters, for instance the "Band" frame may appear with the value "ÿþT" which isn't correct.

It would appear that this program is reading the characters "ÿþ" and then the first letter of the actual value. (this case, being "T") I originally just passed this off as being the problem of the program, but soon noticed that not all the files appeared this way, some actually showed the titles, artists, etc perfectly fine. I still shrugged it off though, until today.

I ran across a second program that performs the same function and noticed that it also showed a similar value. After doing some investigation, I have found that changing the saving method in MP3Tag to ID3v2.3 ISO-8859-1 and saving a file with this option, the values show perfectly fine in both of these external programs. The minute I switch it back to the UTF-16 encoding, the old behavior returns.

Realizing this, I figured it must just be the UTF handling of these programs, figuring they may have been older and not support it or something, but after remembering that I have MediaMonkey set to save in the same format, (ID3v2.3 Unicode UTF-16) I decided I should check it out to see if the programs had a problem with the tags saved by it. So, I re-synced the tags of a test file with MM, and loaded it up in these two programs and it displayed correctly. So, that leads me to believe that there is a problem in MP3Tag causing this issue. I have taken a couple screenshots of one of the external programs showing just one of the Tag Frames.

This is an image showing the "TPE1" frame after saving the tag with MP3Tag:

Same file, same Tag info, this time saved with MM:

As you can see, they are different even though they have been saved with the same option. Is this a bug in MP3Tag, or something else?

PS - My original testing of this was done with MP3Tag 2.37d, but after visiting the development page and noticing that there have been a couple other releases since, I downloaded version 2.37f and it acts in the same manor.


#2

You realize the second picture shows an ISO-8859-1 tag?
So MM did not write utf-16

It's very very likely that your programs don't support unicode tags.
There's nothing wrong with Mp3tag.


#3

What tells you that Image 1 is correct UTF-16 & that Image 2 is ISO-8859-1? Sorry, I'm fairly new to this whole UTF/ISO thing.


#4

In image 2, "Tech" is written as is (one byte or 8 bits per character) while in image 1, "Tech" has a null char appended after each letter (2 bytes or 16 bit for each character).


#5

Thanks for clearing that up. :slight_smile: I have checked this with yet another external program and it is indeed showing the Monkey Tags as being ANSI instead of UTF-16, thus I have reported this to the MM Staff/Comunity. Thanks for pointing this out you two, :slight_smile: