[X] Proxy doesnt seem to work


#1

Hi

I am behind a http squid proxy (172.17.254.8 on port 3128). I have typed in the address and port as well as given the correct user ID and password. However, whenever I do a search i get an:

Error connecting to Server:

I can open my web browser and get to the URLs fine so they're not being blocked by the proxy.

Edit: Just had a look at what happening using Wireshark -- Seems like the HTTP requests are being sent to the correct proxy address. The proxy then asks for authentication but doesn't seem to get it.

Since the password/login are not sent in clear text (understandably) its hard to verify that they aren't being sent. I just assume they are not given that the response to the second http request (the one that should be after authentication) also gets a 407 Proxy Authentication required error.


#2

just wanted to add that I am happy to beta test any interim builds for proxy support


#3

Have you tried the current Development Build?


#4

Yes -- I tried 2.39m


#5

After looking at my HTTP implementation it seems that your proxy does not return status code 407 ("Proxy Authentication Required") although this is required according to the HTTP/1.1 RFC.


#6

Im pretty sure the proxy sends the 407 message. Its just that mp3tag doesn't reply with the correct authentication information. When I get home I will save the wireshark captures and post them.


#7

OK, lol it seems to be working now.

I changed the network connection order in Vista to make my Local area connection that was connected to the Internet the first (Network and Sharing Center --> Manage Network Connections --> Advanced --> Advanced Settings)