[X] VERY strange Genre tag behaviour (for "Comedy" only?)

Hi,

I'm using MP3Tag v2.45a to tag MP4 Video files.

I noticed that my DLNA (UPNP AV) server (Twonky) showed/read all videos that I had tagged with Genre of "Comedy" as "Unknown" (meaning Genre not defined). However, when changing the tag's value to anything else (for example "Comedy2"), the Genre was correctly shown!

I proceeded to check with MP4Box/YAMJ, and to my surprise, the exact same behaviour is seen there (see attached jpg)!

I then proceeded to tag the MP4 file with YAMJ/MP4Box, setting the Genre to "Comedy" in YAMJ/MP4Box, and noticed that (obviously?) it was read correctly as "Comedy" not only in MP4Box/YAMJ, but also in MP3Tag, Twonky, and even Windows 7's explorer (which also shows Genre as blank when tagged via MP3Tag!). I have also attached a jpg showing this.

Can someone (Florian?) please shed some light on this for me please? Why would this behaviour be seen like this, and why only for genre "Comedy" as tagged via MP3Tag?

I have also attached a .zip file which contains "Comedy" tagging as done by Mp3tag as well as YAMJ/MP4box. (I will post this as a second post so as to make it through the 200k upload size limit).



And now the tagged MP4 files...

(A little edit.. I have also uploaded a third mp4 file, which in the pictures in the first post was tagged with Genre = "Comedy2". What is strange is that in mediainfo as well, I see the Genre tag for "Comedy2", but not for "Comedy" for both MP3Taged file as well as MP4Box tagged file!!! So confused... All I want is for my "Comedy" genre to be shown! :unsure: )

Genre_Tag_Strangeness.zip (187 KB)

if you see only the user defined genres, could it be that for some weird reason "Hide standard genres" is enabled?
You find this in Extras:Options: Genres (in the tree).

Thanks for the response ohrenkino!

Since you mention "in the tree" I assume you're referring to MediaInfo. However, I didn't found that option! Strange.

Having said that, I upgraded mediainfo from version 0.7.19 to 0.7.27, and it appears that they changed that behaviour, and I now see the Genre tag (in all cases) in Mediainfo.

However, it still remains that there IS/APPEARS TO BE a difference in the way that mp3tag writes the Genre tag, when compared to other apps (such as mp4box, via YAMB). I say this because (as an example) Twonky Media server (on both Windows and Linux), and also Windows 7's exhibit the behavior I mention in the first post.

(Looking at the windows 7 screen captures above, you'll notice that windows 7 doesn't see other tags from mp3tag as well, while they are seen if tagged using MP4box via YAMB GUI).

No, no, in the tree refers to the options-dialogue in MP3tag - the sub-divisions of the options are arranged in a tree - so please open mp3tag, go to menu extras, function options. There will see the tree.
Could it be that all the other programs write other tags than MP3 V2.3? APE is one of the usual suspects. In MP3Tag activate a column that shows the type of mp3 tag (or open the Tag details with alt-t for a single file). If you see other tags shown in the header than mp3 or mp4 this might be the problem - MP3tag only reads (and writes) MP3 tags properly if there are no other tags with higher priority. APE is one of these. I am not quite sure whether MP4s have the same problem.
So check if the new files really only have a genuine MP3 tag.

Ah, sorry, because in mediainfo there really is a "tree view". Also, I guess you're translating from a non-english version of MP3Tag menu labels, because the translations used are different (for example "extras"). The checkbox is NOT checked (see image below).

At any rate, I think you misunderstood (Or again, I misread)... MP3Tag DOES show all information as written by the other programs. So for example, if I tag a file as "Comedy" in MP4Box/YAMB then open it in MP3Tag, the tag is read. However, if I have the tag in MP3Tag, then other applications (such as the ones I previously listed) seem to have trouble seeing/reading it!

Note that these are MP4 files (you're right about the tag priorities in MP3 though). MP3Tag shows "MP4" only for all the files.

I think Florian has to take a "deeper" look I'm afraid.


Some more interesting (at least to me) findings!

I use a commandline tool called "exiftool" (google will be first hit. Phil Harvey's exiftool) to tag my jpeg pictures. This tool is also able to read MP4 tags.

I ran a number of files through exiftool, and the findings are as follows:

Tagged Genre: Horror
Exiftool output: Horror

Tagged Genre: Romance
Exiftool output: Romance

Tagged Genre: Western
Exiftool output: Western
.
.
.

Tagged Genre: Comedy2
Exiftool output: Comedy2

Tagged Genre: Comedy
Exiftool output: (Binary data 2 bytes, use -b option to extract)

What is strange is that iTUnes, MP4Box/YAMB as well as MP3Tag write the Comedy tag in the binary format, but the MP3Tag one is not readable by some other apps (iTunes does read it, many others don't). Of course MP3Tag can read both its own and as written by other apps.

Finally, I also tested writting a "Genre" tag in itunes into an MP4 file with all tags removed (by MP3Tag). When iTunes wrote the genre tag, it is still in the "Binary data" format, but this tag is readable by MP4Box/YAMB (unlike if written by MP3Tag).

On a side note... I wonder what (if anything) is special about word/genre "Comedy"?

How do you create these mp4 files?

I think this not as a problem of the genre tag as it's written the same way by all programs.
I guess there's something wrong with the mp4 container which other programs might fix when writing the tags but mp3tag can't.

Hi Dano,

Thanks for the response.
I would normally think so, but my testing seems to indicate this is NOT the case. I have tried all of the following:

  1. MP4 files downloaded from the internet, from varying sources
  2. MP4 files generated using X264 (using various front-ends, including xvid4psp).
  3. MP4 files generated using MP4Box

I have a hypothesis based on something that I just tested/observed...
I think we have a bug (or at least require a correction to be more interoperable) in MP3Tag!

In MP3Tag, if you select or type a Genre which has been predefined, it is encoded(?) when written into the Genre tag. However, if you type values that are not in the Genre dropdown, they are written "as-is", in plain text.

From "my" movie collection point of view, the only Genre that overlaps with the (what I assume are) mainly Audio genres is "Comedy". :slight_smile:

So, my other "typed in" tags such as "Horror", "Western", "Drama", etc are all tagged into the MP4 file directly. For the "Comedy" genre having, I believe MP3Tag sees that it matches one of its predefined genres, and applies an encoding! (I tested with multiple of the predefined genres).


I believe the correction is that for MP4 files, MP3Tag should not perform the above matching/encoding!

I just did another check, and notice that tags using another application "MetaX", when run through exiftool are properly showing the Genre tag as "Comedy" and not as "Binary Data"....

What is a little odd to me is that MP4Box also writes binary in this Genre tag. However, that binary value is properly read in ALL applications! It also be that the above "matching" MP3Tag appears to perform results in an incorrect value for MP4 files?

I think Florian will be easily able to see if that is the case or not based on the files that I have attached to this post however.

Edit: Attached a "proper" "Comedy" genre, as tagged by MetaX. The field is not encoded, and properly read by all apps! :slight_smile:

Genre_Comedy_MetaX.zip (10.5 KB)

Good observation. MP4 tags have two different ways of writing the genre

  1. Standard genres (as known from ID3v1) are written to the gnre atom.
  2. User-defined genres are written to the ©gen atom
Since Comedy is one of the standard genres, Mp3tag writes the corresponding genre number to the tags (and not the string itself).

It seems that the other application does not conform to this and should be updated with regard to proper handling of both types of genres.

Kind regards,
Florian

Hi Florian,

Would it be possible to modifiy the behaviour (even if by an option flag) to act as follows for MP4s:

  • If the Genre is a standard genre, write the value in both the ©gen as well as gnre atoms.
  • If the Genre is not standard, then continue as today.

I ask this because I have tried changing programs, but most that I have tried have this bug on their end. :frowning: I have also reported the issue to the application(s) reading the tag (with a link to this forum post), but it's been months now and a fix appears to be no closer than before... It appears to be easier to work around the issue then to get the others to fix.

If you can, it would be great. If not, I understand. :slight_smile:

I'm sorry, but in my experience such workarounds normally result in other problems that are usually harder to fix later.

I'll leave it like it is for now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.