[X] Windows "Snap" feature is not working with Mp3tag

When you drag window to the edge of the screen it should snap to it taking half of screen space, but with Mp3tag it does not work. :wacko:


Windows 7 / Mp3tag 2.81 & 2.81c

It works in Windows 8.1, though.

Hi Solace,

it also works here on my Windows 7 test system.

Kind regards
– Florian

that's strange, Win 7 all of the latests updates are installed..
here is video proof Firefox vs. Mp3tag - https://ufile.io/03tz3

The snap function is set in the "Center for easier handling" (my crude translation)>Using the mouse>Managing Windows>Stop arranging windows.

So perhaps you have to untick that option.

(I also checked on a W7 system and a W10 OS - MP3tag snaps)

it was unchecked, so not applicable here.
I've tried all the apps I could - all of them do snap except Mp3tag, oh well I guess it is some weird special bug just for me :slight_smile:

(I have tried the snap feature on machines that are miles apart and I could not reproduce the behaviour that you observed... So I was really trying))
Just guessing:
Have you tried to start with a "fresh" MP3tag and renamed the mp3tag.cfg file before you start MP3tag? (Honestly: I don't know if that does anything good but there were weird cases where shortcuts did not work any more..)

Or: Have you set MP3tag to run in some kind of compatibility mode like XP?

Ok so I've done some HARDCORE clean install..

  1. Uninstalled Mp3tag (with confirmation to remove all of the files)
  2. Reboot
  3. CCleaner -> Registry Cleaning
  4. Reboot
  5. Mp3tag installation (with Admin rights)
  6. renamed mp3tag.cfg (in AppData\Roaming\Mp3tag)
  7. run the app
  8. ... same thing, nothing improved :wacko:

but during my attempts to stick it to the edge I discovered one weird thing -
if I grab it by the part that is closer to the top right corner (screen: https://s11.postimg.org/fzgcvs6wz/123123.png )
then it does transform to take half of the screen (screen: https://s2.postimg.org/5akcmq4w9/4234243.png ).
BUT.
first - it does not stick to the edge. (instead it appears to be more or less in the middle of the screen)
and second - if I try to move it somewhere (even a little bit) it resets back again (screen: https://s2.postimg.org/u7f0vvth5/234234343.png ).

nope

Maybe ... have a look there ...
https://www.sevenforums.com/tutorials/3069-...p-turn-off.html

DD.20170428.1617.CEST

no, turning Snap feature off doesn't help to make it work :smiley:
(but I've tried even that. when OFF = it doesn't work with any window/app, when ON it does work with all windows/apps except Mp3tag.)

Mp3tag on Windows 10 seems to have no problem with snapping.
Did you read the section "Warning - Aero Requirements to be Enabled in Windows 7"?

DD.20170428.2045.CEST

yes, requirements are met.
Snap feature works flawlessly.. except for Mp3tag :huh:

This is more guess work - you may have gathered, that I think we have a very local problem here.

So: could it be that MP3tag cannot write the mp3tag.cfg? Checking access rights and ownership of folders, even those in %appdata% is a precaution.

Is there some other application running occupies some screen areas like a hidden windows start bar? This could be a special toolbar or a panel to operate e.g. the camera, something like that.

So you have to investigate what might be the special circumstances on your machine.

I use only one user profile on this PC and it has admin rights, so there should be no problems with that.
(but I did check just in case - yep, I have access)

no, nothing like that.
here are all of the processes that are active while only mp3tag is running:

explorer.exe
csrss.exe
CCC.exe (Video Drivers)
Mp3tag.exe
MOM.exe (Video Drivers)
taskhost.exe
taskmgr.exe
dwm.exe
msseces.exe
Ati2evxx.exe (Video Drivers)
SOUNDMAN.exe (Audio Drivers)
winlogon.exe

Pretty clean, also no viruses or any other crap, I keep check on that.
Maybe it is somehow related to screen resolution it is 5:4 (1280x1024) or because of an old video card - Radeon X700 SE (Driver version 2010.0210.2339.42455). Really weird puzzle :wacko:

No, it is not enough to have admin rights, you should actually be the owner of that folder. or alternatively: install MP3tag with the same user id with which it should run eventually.
Also you should be sure that MP3tag really uses the %appdata% folder and not the program folder or some other installation folder as a leftover from a previous installation.

Esp. if you have a migrated windows it could be that the access rights and ownerships are not quite what they should be.

I am the owner and have full access.

mp3tag.cfg and all of the other files are here: (my user name)\AppData\Roaming\Mp3tag
(data / export / Mp3tagError / Mp3tagSettings)

nah.. clean install is the only way to do it! :slight_smile:

If the environment has no glitches, then the snap feature works ...

ok, it seems like we're never gonna find the solution.
it is broken, but I can live with that :slight_smile:
I can provide further feedback if needed, or topic can be closed if admins wish to do so.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.