Yet another Replace question


#1

What am I doing wrong?

I want to remove the initial characters in 24 Title tag entries. I copied the string I wanted to delete, chose the Quick Actions icon (A>a), and selected Replace.

I entered Title in the Field box, pasted the string to be removed in the Original box, left the "Replace with" box empty and clicked OK. Nothing changed.

I'm sure the procedure I used and described above is what I've read in this forum and in several other places.

Thanks
EdP


#2

After you havbe concluded the definition of an action you have to carry it out.
Either tick it in the list dialogue of actions or select it from the toolbar dropdown menu.


#3

Thanks for the response, ohrenko ...

I've used the Quick Action feature several times in the past and it always did its work immediately after clicking the OK button. I just tried it again by deleting text in the Album field and that's exactly how it worked.

I can't understand why it's not working in the Title field.

EdP


#4

It may be that the user feedback by the program could need some refinement.

The dialogue for actions has two buttons: OK and Close.
In my opinion should the OK button only be enabled if an action is ticked. "Close" can work always.
In addition the OK button should be renamed to "Execute x actions" which represents the count of ticked actions - if you have a longish list and you have created a new action it is in my opinion annoying that you have to scroll through the whole list to check which actions you have ticked.

In your case it could be that the action was not ticked or that you pressed "Close".


#5

Perhaps I'm not making myself clear.

I used the Actions (Quick) icon in Mp3tag v2.47b, selected Replace, entered the text to delete, left "Replace with" blank, and clicked the OK button. Here's what the dialog box looks like:


This technique worked with other fields, but is not working with the text in the Title field.

Clue: Perhaps the way I inserted the text into the Title field makes a difference. I used Convert | Filename - Tag

Comments?
EdP



#6

Yes: the only way I could re-enact this behaviour was when I read all kins of tags but wrote only V1 (and not V2).
So, could you check if the tag type that you read are also the tag types that you write? (Extras> Options >Mpeg)


#7

They look the same to me, but we're getting into an area where I have no knowledge or experience. Maybe a picture will help ...




#8

How about updating the program?


#9

In general, when a replacing function delivers no result, then the search string cannot be found in the source string.
So ... check the source string and search string twice - char by char - from the first to the last character.
Look for leading or trailing space characters, check for similar looking characters, because Unicode characters sometimes look the same, but still are different characters.
Does the search string really match the existing string, when you check it manually char by char?

DD.20110422.1640.CEST


#10

Yes, true. But also the function apparently does not show any result if the modification happens in an area that is not dispalyed after by the writing.
E.g. if you set all kinds of tags to be read and removed but only the V1 tags to be written then it looks as though you cannot modify anything by the replace action as the modification is written to the V1-tag but the (unaltered) V2-tag is still displayed.
This is also reflected if you display which tags are read and which displayed. In the above case This is V2 (V1 V2).
You see the replace result immediately if you switch off the reading of V2 tags (resulting in V1 (V1 V2)).
So the settings for
reading should be V1, V2
writing should be V1, V2 (utf16)
and erase V1, V2 and APE.
(This last bit was for EdPell)


#11

Dano ...
Installed latest version, 2.48. No change

Detlev ...
Good point, especially considering the length and complexity of the text string I used. I tried it again, but with 2- and 3-letter strings. Same result. I also tried the format command, eg, inserting some text before the Title text. Didn't work.

I appreciate all your help on this. Having been a programmer (from the 60's), my experience tells me the problem is too simple to be obvious. :slight_smile:

EdP


#12

I am no yet ready to give up:
Could you also check the Extras>Options > Mpc, Ape tree segment (one below Mpeg).
My settings say
Read ID3V1, APE
Write ID3V1 (not APEv2)
Delete ID3V1, ID3V2, APE
Could you also create a column in the list view with the value
%_tag_read%[ (%_tag%)]
to see which tags are displayed, which tags are in that file.
E.g. APE tags usually overwrite MP3 tags.


#13

Thanks for your perseverance!

Ape, Mpc ...

Read ID3v1, APE
Write APEv2 (not ID3v1) [opposite of yours]
Remove ID3v1, ID3v2, APE

Using your specs, I created a column named Tags. Incidentally, there was already a column named Tag with the specs you defined, but wasn't checked. The result was FLAC (FLAC) for every entry.

EdP


#14

For me Quick Action Replace works even on the tag-field TITLE in a FLAC file.

Now shooting in the dark ...

Invoke the Quick Action Replace.
Push the field context button.
Execute 'Reset fields...'
Try replacing again on the tag-field TITLE.

DD.20110423.1734.CEST


#15

Thanks for the patience.
Although all your tags say that they are flac tags I think that any kind of usage of APE tags causes nothing but trouble.
In fact: as APE tags overrule any kind of MP3 tag I bet that you actually did succeed in all your attempts to replace - but you don't see it as the string was replaced in the mp3 tags but on display was APE.
So: if you could adjust your settings that APE is removed, then cut the tags from a file, insert them immediately (to clean up the tags) and then try the replacing on that file I hope that the changes can be seen.


#16

DetlevD ...

That worked!

You do realize that having arrived at the solution, you will be asked by someone to explain why it worked. :wink:

Thanks ...
and thanks to ohrenkino for his determination. Much appreciated.

EdP