Zune & iTunes not co-existing


#1

Have been accumulating MP3s for years.

Recently I got an 80GB Zune to join the boyfriends 80GB video iPod classic.

Using MP3Tag 2.39n, I spent a week cleaning up MP3 tags on all my files. Got all the Aritst names straightened up, album names, downloading album art, etc.

Zune likes ID3v2.3 UTF-16 flavored tags. After cleaning up all MP3s, I re-initialized the Zune library, had it re-import everything, and everything is flawless.

The boyfriend had been using his iPod for months ... while the MP3 tags weren't clean back in those days, iTunes had no problem slurping up all the MP3 files on the computer and then syncing them to the video iPod.

Thinking I had done us all a huge favor by cleaning up the MP3 tags and verifying how beautiful it could all be in my Zune, I loaded up iTunes, nuked it's library and then re-added all the MP3's again.

Only now, iTunes skips about a 1/3rd of all the MP3 files...it just flat refuses to add them to the library (let alone go the next step and sync it to the attached iPod).

Looking at my MP3 folder through MP3Tag, I see that every file reports having "ID3v2.3 (ID3v1 ID3v2.3)" under the "TAG" column.

Zune is completely happy...the Zune software slurps up 100% of the MP3s, syncs them to the Zune, where they all show up properly tagged.

For some reason, iTunes just flat out refuses...when I identify a particular MP3 that it skipped during the bulk import, I try to manually add that file to the library by dragging it into the Library of iTunes. iTunes just ignores me...I might have well not even have drag/dropped the file into iTunes. No error, no success...nothing.

The boyfriend is getting frustrated that now after "cleaning" all the MP3 tags up, my Zune works great and his iPod is rendered completely useless now.

Does anyone have any idea why iTunes doesn't like roughly a third of my MP3 files now?


#2

I don't have an answer, but I can report that I use mp3tag on many/most of my 50k + mp3 files using ID3V2.3 UTF16 (also with ID3V1.1 tags) and haven't had this problem. So while it may be related to your retagging, it is not because itunes doesn't like these tag versions in general. And Itunes shouldn't care about Zunes. I add music to my itunes library, my fb2k library, etc. these libraries are independent of the actual mp3 files/tags.


#3

I couldn't agree more that this shouldn't have a bearing on iTunes importing these files back into it's library ... and yet, cleaning up and re-tagging with MP3TAG is all that happened between back when iTunes had 100% of the our MP3's in it's library and now that it can only pull in about 2/3rds of them. :frowning:


#4

I am having the same issue! All my music was in iTunes then I cleaned it all up with MP3Tag and now only 4k of 12k has imported back into iTunes. I played with just one folder at a time to try to find the problem. I found a folder where only one of 20 songs was recognized by iTunes then I just kept removing all the tags and rewriting them and playing with all the different tag types until all the songs in that folder was good. Then I tried again on another folder and never got any of them to work. I have tried uninstalling iTunes and reinstalling with no luck. I removed all the tag data except Artist and Title. I cannot see any difference in the tags that work and the tags that don't. This is so frustrating!


#5

Don't get me wrong, I'm sorry to hear you are having that problem, but I'm glad to hear that I'm not alone -- misery loves company! :sunglasses:

I just tried removing everything but ID3v1 tags, and that let me import another couple hundred songs, but a couple of hundred still remain un-importable.

I guess if two different people, on two different computers are having this issue, then something just isn't right--somewhere. The way iTunes handles tags? The way MP3Tag writes tags?

I put my money on iTunes being screwy.

All of my MP3's read just fine (seemingly) in Winamp, Zune and of course MP3Tag...as well as Windows Explorer.

Any experts on here have any ideas what could be causing our iTunes import issue?


#6

It definitely has something to do with the tags ... when I remove all tags and leave only the ID3V1 tags, another group of MP3's will import.

But even after doing that to the entire collection, I'm still left with a huge chunk of files that inexplicably still refuse to import into iTunes.


#7

I really have no idea, but you can send me one of the offending files and I'll see if I find something.

Cheers,
Florian


#8

Thank you very, very much for the offer.

I just sent a sample file to your email.


#9

The file actually had 3 ID3v2 tags added by a definitely broken program. Since the first two tags contained a private field with a ZuneMediaID I suspect it was something related to the Zune.

I've removed all tags by pressing Ctrl+R three times and then used Ctrl+Z to bring back the last tag.

Please also note that these files had ID3v2.4 tags. I'd use ID3v2.3 UTF-16 (see Options > Tags > Mpeg) since iTunes doesn't support ID3v2.4 very well.

Kind regards,
Florian


#10

Thanks for that valuable info.

I was not aware that a file could have multiple copies of the same kind of tag on it...I'm guessing that is the case based on you saying that you had to remove tags 3 times...correct?

Zune also likes ID3v2.3 UTF-16 flavored tags like you say iTunes does...so this should be a solvable problem.

So how do you suggest I best proceed?

I see two areas where I need guidance:

#1) How do I set the Tools/Options/Tags/MPEG tag if I only want ID3v2.3 UTF-16 tags on my files? I'm guessing that under the WRITE section I need to leave ONLY ID3v2.3 UTF-16 selected. Under the READ section I have all checked (correct? I would think this would copy any/all info from those types of tags to the newly written ID3v2.3 UTF-16 tag...right?) My big question comes about what do I check under REMOVE, I have ID3v1 and APE selected...should I have ID3v2 selected to remove? Is NOT having ID3v2 selected under remove how I ended up with multiple copies of ID3v2 tags on files?

#2) How do I remove all the extra tags on my MP3s yet keep all of the info that is there though (album, title, artist, ALBUM ART, etc)....and make it so that each file has only one ID3v2.3 UTF-16 (that contains all the above info).

I tried making a backup copy of my MP3 folder (so I didn't screw anything up on my original files), pointed MP3TAG to that backup copy and repeatedly (at least 4 or 5 times) CTRL-R'd ALL files and I got (what I consider) to be strange results--or not what I was expecting. It kept "removing" tags from all files, but when it was done, under the TAG column many were empty...some still had ID3 tags.

It doesn't seem as though there is an obvious option to "Read all the information from all tags, then delete ALL tags associated with the track, and then write ONE tag of type "ID3v2.3 UTF-16" back to the file that contains all the previously read information back into that single tag.

Thank you for your assistance in using this program correctly!


#11

Any program that writes multiple ID3v2 tags is considered to be broken. A file should not have multiple ID3v2 tags stored to it. But from your description below, many of your files suffer from that problem.

Right.

I'd disable APEv2 tag reading since you don't use this tag format.

No, Mp3tag won't write multiple ID3v2 tags -- regardless of the options you're enabling/disabling. This option tells Mp3tag which tag types to remove at File > Remove Tag / [Ctrl+R], so I suggest to enable all options.

It's hard to tell, because it seems that many of your files have multiple ID3v2 tags.

I'd make a backup copy of your MP3s and press [Ctrl+R] till every file ends with an empty TAG column. After that, go to your backup folder and copy all tags using the [Ctrl+C] keyboard shortcut. Now go back to your original files without the tags and paste all tags using the [Ctrl+V] keyboard shortcut. It's important, that the files are in the same order when doing the copy'n'paste trick, so you have to sort them based on path and file name.

Hope this helps!

Florian

Edit: Changed [Ctrl+P] to [Ctrl+V], thanks dano!