3.15 can't drop & drag album art

Had to revert back to 3.14.

Can you try the linked version v3.15a from this topic:

Also, please provide some details on how to reproduce the issue.

Is this a specific, new file?

Because: I just tried to d&d 1 picture to a file with existing cover and had 2 pictures.
I tried it with a file with no cover art and that also worked.
I tried it with 3.15 and 3.15a

1 Like

3.15a works fine with drag & drop art.

With 3.15 I tried both x86 and x64 versions on my Win 10 PC with no success.

As I just had the opposite experience, the function cannot be all wrong.
So it would help if you could tell us what kind of file it is, whether the file has been tested for integrity (which does not mean "it plays"), see e.g. here:

And is this a new file that you just got or an old one that has worked before but now you cannot add pictures?

Great that it's working with the v3.15a version!

As @ohrenkino pointed out, it would be really helpful if you can provide some additional information. I for my part would like to know which steps you've performed to trigger the error and how it manifested itself. Did you get an error message, a crash report, or did it not work as expected?

I've also tried with v3.15 in both versions and everything worked as expected. This makes it even more important to identify the root of the issue.

Two things:


I didn't offer more specifics because the title of my post says it all - pure and simple. I was working on a project where - via MP3tag - I wanted to add the album art to about 900 MP3s. All picture files are JPG 200x200 pixels. All dragged and dropped effortlessly with 3.14. They immediately stopped doing so with 3.15. I used some of the previous JPG files and MP3s to be certain. However, I could always still add Album Art by right-clicking the Album space and selecting "Add Art."


After my initial post here, I did a bit of sleuthing afterward, and am now utterly confused about 3.15. I downloaded both x86 and x64 versions. I would install one (always standard installation), try it, then totally uninstall it via Revo Uninstaller Pro, and install the other. I went through both versions several times. The results; sometimes either version dragged & dropped successfully after an install, and then sometimes not! However, if the install did allow drag & drop, then it did so ALWAYS. The same is true when it didn't allow drag & drop.

I did this on two different Win10 64-bit PCs with all system updates. The same inconsistent results on both. Rather puzzling....

Right now, 3.15 x64 is working correctly on this PC, so I'm not messing with it again!


An aside - Revo Uninstaller shows the x64 version to be 32-bit. Is that an error?

One cause could be that D&D does not work if the privileges of the running program are less than the privileges needed for the files.
Perhaps this is something to investigate.

This is the second user since the 64bit version launched that has had an issue with strange mp3tag behaviour when using Revo Uninstaller.

Perhaps there is something that isn't being handled as cleanly versus the standard Windows uninstall tool?

My issue occurred BEFORE Revo was used.

Thank you for the additional details. I have a better (but not full) understanding on the nature of this issue now.

This is something you can try if it happens again. You can check via Windows Task Manager on the "Details" tab if both processes explorer.exe and Mp3tag.exe are running under the same user (see the respective column).

It's a one-user PC (me). I install and run all programs as an Administrator.

... but if the ownerships and access rights to the files do not match it may also be impossible to drag&drop.
This may be the case if you have the audio files on a separate drive.

Ownership is not an issue in my situation.

But for argument's sake, let's say that ownerships were different. Why would that not be a problem with previous versions as well?

I don't see why this would not also manifest itself with previous versions.

OK. If you run Mp3tag as Administrator (via right-click run as Administrator) and Explorer is in an unelevated state, drag and drop would not work.

I'm not sure how Windows behaves if UAC is completely disabled (what you might have), but I wanted to throw that in as a possible explanation of the mystery.

1 Like

This doesn't seem to be a bug in Mp3tag, moved to #support