ALBUM name missing

(my version is Mp3tag v3.19)
ALBUM name keeps disappearing, as shown in attached pic. Nothing I have done will fill the info in. Any suggestions?

Click on one of those files and open the Extended Tag panel. It is likely those songs have APE tags and they need to be cleaned up. If you can post a screen shot of that Enhanced tag panel this can be confirmed from there.

Cannot find the words 'Enhanced tag panel' anywhere; after right clicking as well.... please elaborate
Blessings, John

From the toolbar you can use this icon;

Or right click on the file and select Extended Tags. You should get a screen like this;

Right click context menu:
will open a pop-up window also called "Enhanced tag panel" or "Extended tags dialog".

Or you can press Alt+T on a file where you miss the ALBUM content.
In the appearing window you can see in the title what kind of tags (ID3, APE etc) you have stored in your metadata.

The next step would then be to check which tag version you read, write and delete.
See Options Ctrl+O and then Tags>Mpeg.

Here's a screenshot. Are settings correct?

Please add a screenshot from Alt+T too
(from one of the tracks without album content in Mp3tag File List.)

If you don't need the APE tags for a specific reason, I would NOT write them into your files.
So I would uncheck/deactivate "APEv2" in the Write-section of the above options.

I would also add to have mp3tag "Read" the APE tags, in case some files do have them. You can quickly find and update all of these files to id3v2.3, then remove the APE tags.

Corrected (Mpeg settings)

Here is the Alt + T (Ext tags info), part 1

Can you show this for just one file? This will help show the actual details. Already you can see that there are plenty of tag fields with content that wasn't there before.

Part 2

So there you can clearly see that this file does in fact have APEv2 tags. When you had the box unchecked for reading APE, these were not being displayed.

You can now work with these files, and update accordingly.

See here for some guidance on saving these as id3v2.3 and removing the APE tags, if that is what you want to do.

@Mobe One more change I would suggest, in the "Remove" box at the bottom of this setting page, uncheck ID3v2 to make sure you don't delete these. Since that is your preference for "Write" I assume you don't want to get rid of them at any point.

According to these settings you read the prioritized APE tags but you do not write them.
This means: they never get updated.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.