Auto-numbering Wizard Providing Unexpected Total Of Tracks

After using the Auto-numbering wizard with a manually input total count of tracks, the originally-supplied count from the application is being saved rather than my input.

Here's what I did:
-With v3.20b (beta) 64-bit, I selected 3 mp3 tracks in the middle of an album of 12 tracks. (I had left the "/12" off the total and wanted to add it in.)
-I opened the Auto-numbering Wizard (selecting Convert, Auto-numbering Wizard or Ctrl+K)

Result: The wizard's total track count was inactive. I expected it to be active.

-So, I unchecked and rechecked "Save total count of tracks" which made the input for total count active.
-I manually entered my total count. (I changed it from a 3 to a 12).
-I also changed the "Begin at tracknumber:" counter (from 1 to 7, to match my starting track.) Then selected OK.

Result: The total tracks that were saved was the original count of 3 rather than my expected 12.

There are plenty of work-arounds, so it's not a pressing issue from my perspective, but I wanted to report.

I cannot reproduce this part. In my installation, the number display remains disabled and I cannot change a value.

Hmmm. Reproducible on my end. I run Windows 11 Home, 22H2, if that's the difference.

Try after removing the check-marks for "Next disc on change of" and "Reset track counter on next disc".

1 Like

Confirmed it works correctly after just unchecking the "Next disc on change of" option. Without this, it is not possible to specify the total track count.

This is probably by design, as I would think if you are running the converter on a series of files, and splitting them using this option, there would be no other way to define the total track count other than the actual existing number for each group.

1 Like

Thank you. I see now how unchecking the "Next disc on change of" option will make the "Save total count of tracks" work as I had anticipated.

With the "Next disc on change of" selected, I'm still not sure that it makes sense to reactivate the "Save total count of tracks" by checking then unchecking, but I will avoid it.

This is not intended and I'll fix it with the next release. Thanks for pointing!

Exactly like that.

This is now fixed with Mp3tag v3.21. Thank you for reporting the issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.