Cannot drop folder with subfolder(s) dragged from FreeCommander


#1

This issue is related with this topic, closed now:

Cannot drop files dragged from a Plain View selection from FreeCommander

In the latest version it works good, plain view + drag&drop, (multiple) folders + drag&drop, F4 multiple files in plain view, late thanks for the fix - just this one still doesn't work:

Drag&drop folder with subfolder from FreeCommander (using %ActivSel% parameter) to mp3tag.

To reproduce, create folder A, create subfolder B in folder A, place some mp3 files in folder B, now drag&drop folder A to mp3tag - it doesn't work. If you drag&drop folder B to mp3tag directly, it works good.

So, if you move many folders, like 30 and 3 have some subfolders, you can miss all files in these subfolders(!).

Workaround, use a plain view (Ctrl+B) to display all files, select all files, focus any file and press F4 or drag and drop to mp3tag. (You can't select all and focus [..] item and F4, this way Notepad is opened)

Using mp3tag 2.94, FreeCommander 794 64-bit, Windows 10 64-bit 1809.


#2

Have you enabled the option in
Tools>Options>Folders>Subfolders
?


#3

Thanks, it works now, no bug, but it's not clear that it's the option for drag&drop.

Anyway, why is it disabled by default?


#4

I don't think that it is (it's not on my installations).
The function has nothing to do with d&d but with reading subfolders.
With that option off,


#5

Perhaps it was changed after I installed it first time, never mind, problem solved.