Cannot upgrade to v3.22 from v3.20

My current version is a confirmed 32-bit v3.20 in C:\Program Files (x86)\Mp3tag.
When running the new mp3tagv322setup.exe the process halts claiming it has found a 64-bit installation in that folder, but a thorough search in the standard and (x86) program files shows no other occurance of an Mp3tag related exe file. Throughout the Registry the only path mentioned is C:\Program Files (x86)\Mp3tag. It's possible to Uninstall Mp3tag neither from Windows settings nor directly with Mp3tagUninstall.exe. I'm stuck with v3.20.
Fully updated 64-bit Win10.

See here for further notes on how to switch from 32- to 64-bit

If you can, install the old 3.20 in 32-bit,
save the configuration,
unistall the 32-bit version
then install the 64-bit version.
Restore the configuration.

Unfortunately installing the old v3.20 doesn't work either!

Not sure, but have you seen the post I've linked to above and tried to follow the instructions?

Yes, as I said uninstalling from Windows Settings doesn't work. The only Mp3tag item there refers to a 64-bit v3.17 that has no uninstall exe. I have installed 32-bit v3.18, v3.19 and v3.20 after that without any issues. There isn't any 64-bit Mp3tag on the PC.

OK, then this version was probably uninstalled by deleting the files, leaving traces in the system that are now causing the trouble. The 64-bit branch of the Windows registry still has entries that are now detected by the installer as an installed 64-bit version.

Can you install this version again and uninstall it via the Windows Settings? Here is the download for mp3tagv317-x64-setup.exe, in case you need it.

Installed v3.17 and then tried to uninstall it from Windows settings, but it complained that this file is not associated with any app.

Interesting: tried to install v3.21, but same trouble. However. v3.20 installed just fine, but not present in Windows settings. Still v.3.17 there.

OK, this seems to be more chaotic than I assumed. You probably installed the "current" v3.17 to a different folder than what's referenced in Windows settings.

Please try the route which was successful in the referenced case and remove the entries manually via RegEdit.exe

Also, I'm moving this from Bug Reports to Support .

Thanks for your patient assistance - it's appreciated! I'll go ahead with Reg cleaning when I have the time.

Did it with tung in cheek, and now v3.22 is running and v3.17 is replaced by v.3.22 in Windows Settings. Excellent support Florian for this great app.

1 Like

Perfect! Happy it's back working and thanks for letting us know :raised_hands: