Can't write configuration file


#1

Ever since upgrading to 2.73, Mp3tag opens an HTML page up when it's opened and when I try to close the program, it says that it cannot write the configuration file. It seems to be a permissions issue, but my permissions seem fine.


#2

If Mp3tag opens the "What's new" page again on every restart of the program, it's indeed an indication that it couldn't save the configuration file due to a file permission issue.

Can you please follow the instructions from this topic and keep us posted?

Kind regards
Florian


#3

Seems to be okay as long as I run the program as an administrator, but I've never had to do that anymore. Also, there is no Mp3tag folder in my local or roaming folders, as the other thread would suggest.


#4

If there is no Mp3tag folder at %APPDATA%\Mp3tag you're storing the program's configuration in the installation directory. This is usually a place where administrator privileges are required.

Did you use the installer to install Mp3tag or did you use another approach (e.g., to create a portable installation)?

Kind regards
Florian


#5

I used the installer.


#6

Same problem under win 10. Changing permissions didn't help.
Deleted and reinstalled 2.73. No effect either.
Appdata folder now missing.
Permissions setting for program files is inactive.
Advanced permissions is set to "full access" for everyone.

It's unnerving. WHAT CAN I DO?


#7

Have you set the explorer to show hidden and system files? APPDATA is a hidden folder.

Deleting MP3tag is probably not the best way - you should deinstall it. Otherwise you might have references in the registry that point to a folder where you have insufficient access rights.

If you cannot alter the permission for the program files folder, then you have not the administrator permissions.

So you have to clean up your system with all the different permission settings.
Set the explorer so that it shows a column with the owner of a folder or file.
If you see weird letter-and-number-combinations, you have to claim ownership for that folder/file.


#8

Thanks for your reply, ohrenkino.

Yes, I did. Still no mp3tag folder in Appdata.

I actually de-installed it and cleaned the registry before re-installing mp3tag.

I do have administrator access. But the "permissions" button for the mp3tag-program files folder is greyed out, only "advanced permissions" are editable. Yet, that works perfectly fine.

No weird letter.combinations. Folder permissions set to access for everyone. Still I get the notorious error message when closing mp3tag.
Any new idea?


#9

Are you sure that you look in the right place, the %appdata% of your user-account under which you started the installation of MP3Tag.

Without restricting the rights every standard user has adminstrator access. Since Windows Vista even the administrator does not have full rights but he is able to get them.
The installation routine of Mp3Tag aks for the rights.


#10

Who is the owner of that folder?
The disabled button is not normal. If you have the correct access, you can set and get everything.
So you have to dig into your local configuration and see how to get the acces rights right.
If you had the sufficient rights, the configuration file would be written without any messages.


#11

That at least is not normal.
The rights should be for one user, the group of administrators and the system account, certainly not for the group of everyone. This folder is user-specific und nor other use should have the right to access it.


#12

That helped. Maybe it's just makeshift but it works.

  1. Right click on mp3tag program files folder
  2. Properties / Tab Security
  3. Found my account name mentioned twice, as "administrator" and as "user". "Administrator" had full access, "user" hadn't.
  4. Gave "user" full access too.
  5. Properties / Tab Sharing / Advanced Sharing (as Sharing button is still grayed out)
  6. Permissions button
  7. Add user "User". Make sure "full access" is ticked.

DONE. mp3tag error message is gone.

Thanks for your help.
By the way, after having re-installed mp3tag in Windows 10 there's definitely no mp3tag folder in any user appdata path.


#13

You should be aware, that this is certainly not a correct Windows-Security-System. No user in windows program folders should have full rights for acces.

But where is mp3tag storing its files (actions, exports, sources ..-)?
In the program folder?

The correct place in not so old windows-versions that a program should use for its data ist the %appdata%-folder (username\appdata\roaming) and MP3Tag makes use of it and creates subfolders during installation.

So I think you cured the symptons but not the reason for your problem.


#14

Thanks again for all your comments but we shouldn't get confused about the real problem:

The mp3tag's error message occurred after installing the 2.73 update under Windows 10.


#15

So is manually changing permissions the only way to fix this? As poster noted, I shouldn't have to change access rights for any of my folders. Could a fresh reinstall fix the problem?


#16

Depends.
The access permissions problem canonly arise if you had a kind of messed up installation in the first place, like a portable one that still resides in an official program folder or something.

You would have to take care that all, really all traces of a previous program version are removed from the PC. Including shell extensions and references to an installation folder.

Then you would have to install MP3tag with the same user account that should use it in the end, just to be sure.
I doubt that this is easier than modifying the access permissions of a folder.


#17

Hey, I've has this problem several times, and I've checked to make sure that the "Mp3Tag" folder in "Users\Me\AppData\Roaming\Mp3Tag" is owned by me and has Write permission, and I still get this problem intermittently. I'm running version 2.9.1a under Windows 7 x64. I checked again and ownership/permissions haven't changed. AND the .ini fies seem to be getting updated - at least they have a modification date/time that implies they are. Yet I still get the message sometimes.

Also, if I open Mp3Tag and change a few settings (columns), then close the program, I notice that the "User\Me\Roaming\Mp3Tag" folder shows up as containing read-only files. But if I look in the folder, none of the files in it are read-only. When close Mp3Tag and change the folder, subfolders and files to NOT read-only, and then open and close Mp3Tag again and check the Mp3Tag folder, the folder again shows up as containing read-only files, as if Mp3Tag itself is altering permissions. Has anyone else experienced this?


#18

That is weird as usually data processing either works or it does not.

You could create yourself a debugging tool in Tools>Options>Tools
that calls the windows explorer with these parameters:
'/e,"'$getEnv('MP3TAGAPPDATA')'"'
This should open the explorer in the folder where MP3tag expects its data files.
And in this folder you should check the permissions and stuff.

If you get the problem really intermittently then you should see what kind of virus checker or indexer or similar backgorund processes run on your system and why it blocks access the configurations files.


#19

Thanks. Do you have any idea why the folder is being set to "partly write-only"?


#20

I think that is the case for every folder in the %appdata% folder.