Copy individual fields adds field on paste instead of replacing


#1

As I read it here Mp3tag v2.91 released there was this new feature

And so I installed the new version and when straight to it. And there is a bug apparently:

The field is copied - but instead of replacing the existing one, another is created with the same name


I tried different fields, both legit and made up by me. I tried coping between two MP3 files and tried combination like e.g. FLAC > WV, TTA > MP3. The result was always the same: a creation of a doppelganger. And what is more, I can multiple that field to infinite numbers / versions, so that for example I can have two GENRE fields with Rock and 10 GENRE fields with Pop and 1 with Hip-Hop, all within one and the same file


#2

Confirmed.

I think it is a bug.
But I like this behaviour as an alternate option if you intentionally want to create multiple tag-fields or just to be sure to not overwrite things by accident. To delete the unwanted content later is easy.

My suggestion therefore: A 4th selection beside Cut, Copy, Paste: "Replace".


#3

It could / should be a choice in Settings: if CTRL + V is to add another field of the same name or to replace [overwrite] it; with the default set [IMHO] to overwrite


#4

I don't think so.
Hidden in settings it would be much too laborious to use these 2 options.
Before I change the settings in Mp3Tag in order to create a multi-tag-field this way I would edit the tags manually.


#5

You have a point poster, as I think I understand how you understood me

But what I really had in my was this: [assuming this bug will be left as an option] I would like to be able to turn then that option off- so that in my Mp3tag I would not have at all an additional Replace entry in that small menu that now consists of Cut, Copy and Paste. Or to make it informative, rather have the Replace not removed completely but have it greyed out [so that looking at that menu I would remember that this was my choice and there is a place somewhere in Settings where I can turn than back on]


#6

I've moved this to #support as it's intended behavior. As a workaround for now, just remove any field you don't want to have duplicated.