Cover Art wird nicht angezeigt

Hallo,

das von mir eingefügte Cover Art wird unter Windows 7 und XP in der Symbolansicht nicht angezeigt. Bei mp3s aus Downloadstores klappt es aber. Mir ist nicht klar was ich falsch mache.

Die mp3s liegen in einem Ordner, darin befindet sich jeweils ein Bild als folder.jpg. In den Optionen habe ich unter Tag Quellen - Datei für Cover Art "folder" angegeben. Im Hauptfenster und unter Erweiterte Tags wird es auch angezeigt.

Mir ist nicht klar was ich falsch mache.

Gruss,
frankyboy




Du machst eventuell gar nichts falsch, den sollte das Bild gar nicht im ID3 Tag der Datei gespeichert sein, so kann Windows dies im Explorer auch nicht anzeigen. Ich bin mir nicht sicher, aber ich glaube das Mp3tag auch ein Cover anzeigt, wenn es als folder.jpg im gleichen Ordner wie die MP3 Datei vorliegt. Das könnte der Grund deiner Verwirrung sein.

Lösche bzw. verschiebe die Datei folder.jpg aus dem gleichen Ordner der MP3s und öffne dann nochmal die MP3s in Mp3tag, wenn du nun kein Cover mehr siehst, dann kannst du dir ganz sicher sein, dass das Cover gar nicht im ID3 Tag gespeichert ist.

LG Jens

Hab ich gemacht. Das Cover wird aber in mp3tag angezeigt und lässt sich auch aus den mp3s extrahieren. Also kann ich doch davon ausgehen das das Cover in der mp3 steckt!?

Wie müsste den der Formatstring aussehen wenn ich über Aktion und Album-Cover aus Datei importieren das Bild in die mp3s schreibe?

Gruss,
frankyboy

Andere Nutzer haben im Umgang mit Win7 die Erfahrung gemacht, dass andere Inhalte als die Dateiattribute nur gezeigt werden, wenn die Indizierung für das Laufwerk eingeschaltet ist.
Du müsstest also im Explorer das laufwerk mit der Musike aussuchen, mit rechter Maustaste den Eigenschaftendialog öffnen und mal checken, ob das Häkelchen bei
"Zulassen, dass für Dateien auf diesem laufwerk Inhalte zusätzlich zu Dateieigenschaften indiziert werden."
setzen.

So sitzt im Moment nur das Ikönchen für das Programm, das die Dateiverknüpfung hat, da drauf.
(Hat also nicht so richtig was mit MP3tag zu tun, sondern ist ein Explorer-Problem)

Das sitzt schon. Hab auch die Unterordner gecheckt. Außerdem werden die Cover-Bilder ja, wie oben beschriebn, bei manchen mp3s, die ich nicht selbst getagt habe angezeigt.

In der Tat ein eigenartiges Problem.
Der Formatstring muss hier einfach "folder.jpg" heißen, wenn die Datei im selben Ordner ist. Das Ergebnis müßte aber meines Wissens das gleiche sein, wie wenn du das per Rechtsklick im Vorschaufenster des Tag Panels machst.
Aus deinen Screenshots wird auch klar, das das Cover eigentlich korrekt eingebettet ist. Sonst würde da nicht "image/jpeg" sondern "folder.jpg" stehen. Auch wird es korrekt als "Front Cover" angezeigt, was glaub ich der Standard ist und bei mir in Windows Vista immer ohne Problem dargestellt wird.

Was für Tags haben die Dateien? ID3v2.3 ?

Prüfe die Dateien auch mal mit
http://mp3val.sourceforge.net/
Wenn die Mp3s z.B. falsche Größenangaben im Header haben zeigt der Explorer bei mir keine Cover an.

Problem gelöst! :smiley: In den Optionen von mp3tag war ID3v2.4 eingestellt und das versteht Windows 7 wohl nicht. Mit 2.3 klappt es. Danke an alle!

Siehe Bild:


Warum fehlen in diesem Bildschirmfoto, das den Dialog "Erweiterte Tags..." anzeigt, die normalerweise in der Titelzeile angezeigten Informationen zum verwendeten Tag Format und zum Dateipfad?

Das ist doch klar, weil im Hintergrund mehrere Dateien selektiert sind, was man auch aus den angezeigten Platzhaltern "< beibehalten >" schließen kann.

Ein solches Bildschirmfoto erleichtert die Fehlersuche selbstverständlich nicht.

Wenn nur eine Datei selektiert ist und davon der Dialog "Erweiterte Tags..." angezeigt wird, dann sieht man schon an den Angaben in der Titelzeile, welches Tagformat in der Datei vorhanden ist.

Die Lösung und Antwort für das Problem wäre sofort offensichtlich gewesen (==> unpassendes Tag Format).

Hmm ... frankyboy ... da hast du uns wohl extra 'auf's Glatteis geführt', oder?

DD.20110306.1010.CET


Bestimmt nicht.

Hallo an alle,

ich möchte dieses Thema noch mal aufgreifen. Ich habe dasselbe Prob. das bei meinem Win7 HP die in den Tags gespeicherten
Cover nicht angezeigt werden.
Ich habe schon den Icon-Cache erhöht. Dann habe ich alle in diesem Thread beschriebenen Punkte umgesetzt.
Das heißt auf die richtige ID 3 Tag Version geprüft. Die Indizierung ist eingeschaltet. Mit dem Prog. mp3val die Dateien geprüft, Fehler
gefunden, Fehler beseitig.
Anschließend mit MP3Tag wieder alle Dateien neu mit den Tag Infos inklusiv dem Cover versehen.
Das Ergebnis der Explorer weigert sich nach wie vor die Cover anzuzeigen.
Im Media Player werden die Cover korrekt angezeigt.

Hat noch jemand ne Idee woran es liegen kann ?

Bis zu einem bestimmten Zeitpunkt hat der Explorer die Cover auch angezeigt. Irgendwann, leider weiß
ich nicht mehr wann und nach welcher Neuinstallation bzw. Update, wurden die Cover nicht mehr angezeigt.

Viele Grüße

Das heißt nichts, wenn du nicht zuvor den Grafikcache von WMP gelöscht hast. Dann kann es nämlich sein, dass du noch die alten Bildchen siehst.
Wie sieht es denn mit den EInstellungen im Explorer aus?
Da gibt es z.B. "Immer Dateisymbole zeigen statt Miniaturansichten". Ist das vielleicht nicht ausgeschaltet?

Hallo ohrenkino,

ist eingeschaltet. Es hat ja auch schon mal geklappt. Ich habe nichts an den Einstellungen geändert.
Den WMP Cache habe ich noch nicht geleert. Wie geht das ?

Gruß

Nein, diese Option muss AUSgeschaltet sein. Denn sonst siehst du nur die Dateisymbole.

Für den Cache guck mal in

c:\benutzer<kennung>\appdata\local\Microsoft\Media Player\

Da ist ein Verzeichnis "Grafikcache".
Das mal löschen.
Wird danach ggf. wieder gefüllt.

Das Löschen des WMP-Caches bringt m.E. die Bilder nicht wieder. Das ist eine Explorer-Sache. Der Rat mit dem Löschen bezog sich mehr auf die Aussage, dass der WMP die Bilder (noch) zeigt.

Sorry, hab mich vertippt. Sollte ausgeschaltet heißen, sprich er soll Miniaturansichten darstellen.

Gruß