Creation of playlists one per folder does not work any more

This has been such an invaluable feature - however, it has stopped working in the most recent release.

Which is your most recent release?
Which function did you use with which parameters?
(As I can still create playlists)

I am using v3.16 (64-bit)
I have been using the playlist function for years to create individual playlists for each folder in a hierarchy.
Ctrl-Shift-P no longer does anything whatsoever.
Ctrl-P as well as both playlist options under the File menu create a SINGLE playlist in the First sub-folder containing all tracks elsewhere in the hierarchy.
I have messed around with the various settings for playlists, but to no avail. I cannot restore the ability to create individual playlists per folder.
My Filename pattern is: %_folderpath%\playlist.m3u8

This has always been such a useful feature, and I am really missing it!

I have not investigated to see if the problem is also present in the 32-bit version.

EDIT: It is like the folder recursion functionality is not working. I just tried the export feature and it fails as well UNLESS I use the append data option. Without that the "One File Per Directory" function does not work, and the lone file in the root is overwritten each time, leaving just the last.

I just used %_folderpath%%album%.m3u8 in 3.16e 64-bit
with the ticked option to show a confirmation dialogue for the filenames and then pressed
and got 3 confirmation dialogues and 3 separate playlists ...
Which means: I cannot reproduce it.
So: did you follow the additional notes when you installed the 64-bit-version?

Yes, I followed those correctly. All of my settings, sources and actions are behaving as expected. the only aberration is this playlist and export functionality. The feature seems to be recursing the folder tree to identify tracks, but is not recursing when saving the playlists. It's very odd, and very frustrating. I may have to revert to 32 bit to see if the problem persists in that environment.

And have you tried to install MP3tag again with saving the settings first, then a clean de-installation, an installation and restoring the settings again?

The lack of functions that you experience is by far no normal MP3tag feature.
And as I can't reproduce it, I would say it is something local.

What happens when you hold only the SHIFT key while clicking either of the File menu playlist options?

1 Like

Ah, that actually works! I wasn't aware that was a possibility.

CTRL-SHIFT-P is not registering properly as a shortcut for some reason.

This IS an effective workaround though, so MANY thanks for the suggestion!

1 Like

I have tried that. I have now also tried a complete uninstall, and clean install of 32-bit version with the same result. CTRL-SHIFT-P is not registering as a shortcut. Holding SHIFT while selecting "Playlist (Selected Files)" does actually produce the correct result, so I now have a functional workaround. It's very odd.

I've also followed this topic with curiosity and couldn't reproduce the issue on my test systems.

Is there any change on your system that might be related to that? What version of Windows are you using?

It is certainly odd behavior. I do regularly update the system and software so changes are quite frequent. That said, I ran some tests by explicitly halting as many processes as possible to see if there is any unwanted interaction with other applications on this system; to no avail.
I am running:

Edition Windows 10 Pro
Version 21H1
Installed on ‎10/‎18/‎2021
OS build 19043.1826
Experience Windows Feature Experience Pack 120.2212.4180.0

All other shortcuts seem to be functioning normally.

CTRL-P produces a single playlist file for al currently loaded tracks
CTRL-SHIFT-P does nothing

Holding SHIFT while selecting "Playlist (All Files) from the menu, works properly.

If a different application has "hijacked" the CTRL-SHIFT-P shortcut, I am unable to identify it. I have even used "Ethervane ActiveHotkeys" to see if a global hotkey assignment is interfering; CTRL-SHIFT-P is not present in the global list.

It's a mystery at this point, but at least there is a workaround by holding SHIFT when using the menu entry. It had been my desire to add playlist creation to one of my actions, but that does not seem possible and would constitute a feature request, I believe.