Error "updating" tags

Yesterday this started happening, 2 days ago it worked normally. Everytime I edit tags in mp3tag they updated normally with the pop up showing they updated succesfully, but in the folder where the audio is in, doesnt show the tags. Tried updating and nothing, also restarted and nothing. But everytime I go to an online tag editor, it shows that it has the tags and cover image. When I open the audio with groove music, no tags appear and same in my phone, nothing. How can I solve this? It happens with everytrack I download since yesterday and works normally with previously downloaded tracks.

AUDIO IN ORIGINAL FOLDER

AUDIO IN MP3TAG
.

(BOTH FILES HAVE THE AUDIO SELECTED)

You are asking why your windows file explorer doesn't show tags like GENRE or DISCNUMBER or YEAR?

What about a right click on one of your existing file explorer columns ("Titulo" or "Album") and add the additionally wanted columns (GENRE, YEAR)?

Adds them but it adds them to the other audio files, On The Wings Of A Rainbow still doesnt have tags, if you open it in Groove Music (the windows music app) it shows like a normal audio file with no tags

This is one of the usual windows settings.

You have to add your columns for every folder with music (windows will remember it per folder)
OR
You have to define the view for ALL your music folders:

doesnt work, the problem is that the tags are saved in mp3tag and only appear there or any other tag editor, but dont update on windows, its like if I have downloaded the audio without editing tags, it doesnt have anything to do with shown tag columns in a folder or something

Please click on your song #23 "On the Wings of a Rainbow" in Mp3tag and then press ALT + T.
Can you show us a print screen of the "Extended Tags"?

Could you check the features of your player? IMHO this is a player problem as MP3tag shows all the tags as they should be. So how should MP3tag add functions to an external program?

Besides the

as @LyricsLover requested, could you check which tags you read and write, what file types you try to handle?


Here you go

To summarize so far:
1.) In Mp3tag your metadata appears as expected. Everything is OK in Mp3tag?
2.) After a metadata change in Mp3tag you can't see this change outside Mp3tag, not in windows file explorer and not in "Groove Music"?
3.) If you use an online tag editor, you can see your metadata changes?
4.) This behaviour started one day ago. All files changed more then two days ago show their metadata correctly everyhwere (Mp3tag, Windows File explorer, Groove Music, Online tag editor)?

Yeah, in 4 is basically files downloaded more than 2 days ago

Can you please show us a print screen of your current Mp3tag settings for
Tools -> Options -> Tags ->
1 x Mpeg
and
1 x Ape, Mpc ...

Here you go

srftjtdftj

ojgsjinsgo

I'm running out of ideas, unfortunately.
Does anyone else have a guess?

As the files have been downloaded, anything could have happened to them.
So please use mp3val and mp3diags to see if they are OK.
Here are the links:

When I scan it, at the side of the file it says PROBLEM, here's what it shows at the bottom of the program

Analyzing file "C:\Users\Encar\Desktop\Música y Álbumes\Legends From Beyond The Galactic Terrorvortex\23 - On The Wings Of A Rainbow.mp3"...
WARNING: "C:\Users\Encar\Desktop\Música y Álbumes\Legends From Beyond The Galactic Terrorvortex\23 - On The Wings Of A Rainbow.mp3": Too few MPEG frames (it's unlikely that this is a MPEG audio file)
INFO: "C:\Users\Encar\Desktop\Música y Álbumes\Legends From Beyond The Galactic Terrorvortex\23 - On The Wings Of A Rainbow.mp3": No MPEG frames, +ID3v1+ID3v2, CBR
Done!

I noticed that the file doesnt show Coded, bitrate, frequency or lenght in mp3tag

I would take that message seriously. That file is broken beyond repair.

Hey, I tried downloading the mp3 from another site and apparently the mp3 downloaded correctly, so the problem was the site where the mp3 was downloaded