Export to columns

Is there anyway to export to Excel in a column format? I'd like to be able to delete some of the information and re-arrange the remainder of the information when exporting to a csv. Currently each line exports to a single cell and the information (Title, Album, Genre, etc.) can't be globally manipulated.

Can you give an example? I'm not sure if I understand you correctly.

When I export using the csv option all of the linear information is exported together to the same cell, for instance in one cell it looks similar to:
c:\documentsandsettings\abbafernando3:28mp3pop3142kb and so on. I can't delete columns or sort in anyway because all of the above is in just one cell (column). I renamed the original export file and then played around with some of the syntax but I'm by no means a programmer and it showed. I also looked around the forum and got some ideas but none of them worked for me, probably associated with my not being a programer. I also modified the columns by deleting all the columns I did not want to see when exporting. When I look at them while using the program only those I want to see show up but when exporting they all show up as above. Thanks in advance

Please read this and come back with your questions:
Zu doof für Export?
CSV output


I saw this last weekend and cut and pasted but got the same syntax error. That's when I started playing around with the coding but not being even an entry-level programer I didn't have much success. I was smart enough however to have renamed the original csv file so that when I was through screwing up in my attempts I could un-rename and get back to the original.

I think the problem that all information is exported to one single cell might be caused by Excel not recognising the semicolon as a column separator.

Can you please try to replace all semicolons by commas in the export configuration (or vice-versa if you already use commas as column separator).

Which version of Excel are you using?

if you just doubleclick a CSV file it will open in Excel but the semicolon isn't recognized as a delimiter (at least with Excel up to version 2003).

so first start Excel and File Open your CSV file. you will get a wizard letting you specify your delimiter ...

(we had a similar problem in this (German) thread: /t/2798/1

HTH, andreas

this is what I get when I export as a cvs file. It compressed into one cell.

Did you follow the advice in the post immediately above yours?

and also:

You need to make sure you are using a unique identifier as the separator for the data you export from mp3tag. I use the Section sign § (Alt+0167) since it is highly unlikely to be used in most tags. After the file has been exported, you have to start Excel separately, then use Open your saved export file from within Excel. You will get a wizard that will prompt you through the steps required to get the columns, including one that will let you define the separator you chose.

I posted some screenshots from the Excel options for CSV in this thread:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.