[F] Sending multiple files from foobar to Mp3tag does not send them all

bug-fixed

#1

I saw this behavior in last (3? 6?) month. Win7x64hun, Mp3tag allways the last (beta too), foobar allways the last (beta too). Earlier (through years) scripts worked without problem.

When I send multiple files from foobar2000 (using Run services) to Mp3tag, not all files "landing" in Mp3tag's list, only some (sometime only 1) of them. Repeating 3-6 (!) times the operation in foobar usually resolves the problem.

Sending files from Total Commander I never saw such behavior. I think, it is associated with foo_run (and it is Florian's brilliant work, too - thanks for it!) or with foobar itself.

2 scripts in Run services are:
"C:\Program Files '('x86')'\Mp3tag\Mp3tag.exe" "$substr(%_path%,0,$strrchr(%_path%,''))"
and
"C:\Program Files '('x86')'\Mp3tag\Mp3tag.exe" "$left($directory_path(%_path%),$sub($len($directory_path(%_path%)),$len($directory(%_path%))))"

Using the second script (sending folders) the bug seems much less often, not all times. Using the first script (sending files) seems in 95% of cases.


#2

It seems you have similar problems to those of mine of Mp3tag and Free Commander "send to" options

http://forum.audacityteam.org/viewtopic.php?p=309863

http://forum.freecommander.com/viewtopic.php?f=18&t=7106

They most likely have little in common with your issue, but maybe reading those will guide you toward if not explanation then at least a workaround


#3

Zerow, thank you for your reply. I read them - but still my workaround left the click-click-clik... :slight_smile: Or, drag and drop.


#4

But I see, in my first comment I did an error. Those 2 scripts are not for sending files, or sending folders, but for folders and parent folders. The right ones:

  1. Send file(s)
    "C:\Program Files '('x86')'\Mp3tag\Mp3tag.exe" "%_path%"

  2. Send directory(s)
    "C:\Program Files '('x86')'\Mp3tag\Mp3tag.exe" "$substr(%_path%,0,$strrchr(%_path%,''))


#5

So did you managed to get rid of the bug?

Or that your solution only work a certain percent of the time?

I've managed to overcome my problem with sending files from FreeCommander to Spek and Spectro [http://forum.freecommander.com/viewtopic.php?p=24094#p24094] but I completely forgot, that I also have a problem when sending files from FreeCommander to Mp3tag [http://forum.freecommander.com/viewtopic.php?f=18&t=7106]

One file is not a problem. But when selecting multiple files for sending, not all of them are loaded to Mp3tag; and that bug doesn't seem to follow a pattern

[I've recently tried different settings if FreeCommander, even more than why I dealt with the Spek and Spectro issue, but It didn't helped]


#6

No, I could not.

My "solution" (click-click-click...) in fact, not a real solution; so much the more, in case of ~10< files does not work.


#7

It seems, that 2.85e solves this probleme. :slight_smile:

Little later: not every time :frowning: -- but in most cases (nearly 99%). Big difference! :smiley:


#8

Just out of curiosity, I was reviewing posts and came across something that may be useful to both of you or may not be...you decided but here it is...

HowTo - Start Mp3tag from Total Commander


#9

Hmmm

I could switch to Total Commander; or point out the makers of FreeCommander to this TC solution, in hopes of them utilizing it somehow

Thak you


#10

Since then, I have not noticed the error. 99% seems to be 100%, so, Florian, in my opinion the original bug (foobar>>Mp3tag) now is fixed ([F]). And thank you for the correction.


#11

Sorry, the problem is back. :frowning:
I tried: 2.87a-b-c
Ready to try other versions, if Florian thinks, and sends me (or points to) the installer(s).


#12

Solution.


#13

@stevehero
Thank you for your tip. Sorry, it does not solve the problem, at least for me.
"C:\Program Files '('x86')'\Mp3tag\Mp3tag.exe" "%_path%" sends only the first selected file to Mp3tag, whatever settings (wait, thread...) I use.

And, in general: any program without english help is not serious in my eyes. Japanese help file with google translator is not my best best friend... I gave it up.


#14

Here's the syntax. I didn't need to translate the help. I got it to work without.

"C:\Program Files '('x86')'\Mp3tag\Mp3tag.exe" "$replace(%_path%,%_filename_ext%,)"

Screenshot of my setup


#15

"$replace(%_path%,%_filename_ext%,)"
This sends whole folder. I want to send selected files.

But I have a new idea. Try to find previous version of foo_run, and test it.
...
Sorry, could not find it. @Florian, may I ask you to point to?

Stevehero, I think, previously you did not understand me exactly. Not (only) the help file itself is the point. If a public program does not have english help, it means, that its creator does not care about users. He is negligent. And such quality is the program itself. For such a program to spent a big time: error.


#16

Why is the quality of it determined whether or not the help is in English? Not everyone speaks it as their first language.

Anyway, here's your fix.
Path: "C:\Program Files '('x86')'\Mp3tag\Mp3tag.exe" "%_path%"
Album grouping title: %title%


#17

Thank you, @stevehero, now it works.

But, unfortunately: it repeats exactly the same symptoms, as foo_run. I selected 58 files in foobar, foo_run_group sends (tried 4×): 57, 7, 51, 52 files. :frowning: But it helped (someone...) in diagnostics: from foo_run remained only common with foo_run_group elements (+foobar and Mp3tag, of course).

Later I shall diagnose it with clean fresh foobar installation, adding plugins one-by-one. May be, one of them conflicts with foo_run (and same others). Sending multiple files from Total Commander (or Explorer) through the shell works without problem.


#18

Maybe try %_path% in the Album grouping title and check the wait checkbox.

Works every time for me.


#19

Does not work, because of wait checkbox.
Without: sometimes work well, sometimes not. Same, as foo_run. Tried many times. Foobar refreshed from last stable to last beta, no difference.


#20

Only as an "indicator" :smiley: -- the behavior still persists.