Fixing drag and drop not working in v3.02 on Windows 10

I have MP3Tag V3.02 in my PC and I have 2 problem in using it a few days ago. And now I can fix it, so I'd like to share them for you.

  1. I can't open MP3tag normally, so I have to set compatibility mode to windows XP to run it, or run as administrator.
  2. Drag and drop not working after I have installed new windows10, but it worked before.

My Solutions is setting the current user to be the OWNER and FULL CONTROLL PERMISSION to these 2 folder...

  • C:\Users[username]\AppData\Roaming\Mp3tag
  • C:\Program Files\KMSpico (in case you use crack windows)

For the process how to assign the owner and permission for a folder.
Just right click>security>advance... And here they are.

Sorry for bad English, I am from South Asia.

All what you suggest are actually not real solutions.
MP3tag is only the messenger that your system is really messed up.

Drag&Drop does not work if you do not have sufficient access rights for the files that you want to process. You are right to adapt the security settings - yet this would not happen if you install W10 with an in-place installation under an already existing user-id as then all user permission would be kept.
Setting MP3tag into XP-compatibility mode is definitely not the way to do it, MP3tag runs perfectly under W7, W8, W10 - the problems probably arise from the strange way your Windows has been installed.
To clean up the installation, install MP3tag again under that user-id with which you intend to use it.
I expect that you run into problems with other programs as well.

Thank you for your answer. I have try many solution...

  • uninstall mp3tag, clean registry, deletted all file about mp3tag. And re-install under my current user(as administrator). But It did not fix any thing.
  • Run MP3tag as administrator or set to compatible XP mode but it still not be able to drag and drop a file.

Finally it work by the step I posted above. And I think it should be benefit for someone elf, because I have searched over the internet, there is no one can fix this ploblem.

This is a log file about the error when I run MP3Tag normally. Could you please look.Mp3tagError.log (2.0 KB)
runtime error

Here is a thread in this forum about drag&drop not working:

The XP-compatibility mode point IMHO to a basic problem with your Windows installation. MP3tag is only the messenger but not the cause. And it is not the purpose of this forum to to get that right. Setup a proper Windows and MP3tag will run without any of the described problems.
As I said: I assume that you will run into problems with other applications.

Hi,
If you read carfully. I didn't mean MP3Tag cause this problem, so why I didn't post in Bugs sections. It is just some wrong setting in my system. And I can fix it out. Here in this forum we talking about MP3tag, where would you like me to post?

I have readed that thread before, and for me assigning access right only to mp3tag.exe or mp3tag.cfg didn't help.

Changing compatibility mode to XP, help me to open the program, but not fix drag and drop problem. For now, I can run it in normal mode and drag and drop working too. No need to install a new window.

My windows may have some thing wrong but the other aplications work very well.

Thanks.

Hi Athaset, I tend to agree with Ohrenko in this. I have a suggestion that you may want to consider. Firstly, create a new LOCAL user account and grant it administrator rights. Login as that user so it can set the desktop up. Logout & log back in. Next, from an elevated command prompt (right click on command prompt) "sfc /scannow". If it reports errors (corrupt files) and states that it has successfully repaired them, reboot the machine. Run the same command again. Hopefully at this point it will no longer report errors. If it does do the process yet again.

If after several attempts, it is still not happy, move on to the next step which would be to run the command "dism /online /Cleanup-Image /Restorehealth". Usually this will work to clean up some of the windows components.

Reboot yet again and see if the sfc / scannow reports no errors. If errors are reported again give sfc/scannow a final try but by then, I would think a deeper investigation would be required since it would most certainly indicate a deeper problem with the build. You may need to do an inline reset/rebuild of the machine. If all is good, re-attempt installing MP3Tag under the newly created user's profile and see how that goes. MP3Tag certainly does not require XP mode. MP3Tag has always a no brainer install for me and I have installed it many a machine without the issues you are reporting.

If you have ever been inclined to use a "registry" repair tool, that in itself can cause lots of grief, so be forewarned and generally speaking (IMHO) they tend to cause more harm than anything else. Indeed, one very popular cleaner will regularly point to issues with my system. If I allowed the cleaner to do what it wanted, my Foobar installation would get scrambled, my older Office installation (broke outlook) would also get trashed.

I hope that the above provides you some useful guidance