FLAC files on NAS causing hang

I'm using 3.21 on Win 10 and have run into an issue. Lately the program will hang when writing tags to FLAC files. I can't get MP3TAG to quit even when using Task Manager and choosing to End Task. MP3TAG acts like it has quit, but hasn't. The program won't start again until a reboot of the system. I've tried using the MACOS version as a test to see if it's just related to Windows and the FLAC files still create an error. The description of the error is being reported as "can't write to file, you don't have permission". I checked the file permissions (they reside on my Synology NAS) and the permissions are correct.

And what happens if you move some of these files to a local drive and try to write to them?

Tried that on the macos version, that's when I received the "can't write to file, you don't have permission" error.

see e.g. here:

I copied the problem flac folders over to the local machine and it worked. I've rebooted the Synology thinking that could be an issue. I still need to reboot the network to see if that could be an issue. I've had to take extra steps to tag/move the files but it's done. Not as smooth as MP3TAG has made it in the past (like 2 days ago). Great program!

Have you tried the way with deleting the secure bookmarks?

I don't think that's relevant in this case.
The macos version allowed to see what the error was. Some of the FLAC files are pretty large.
I've thought about moving the files locally, and move them back to the NAS, but in total that would be over 3TB. I'd rather just write the tags on the NAS files.
I may just need to deal with it, but MP3TAG has been a great resource!

BackLog is an option to gain some insight to what's happening on the Mac. You can set the process to Mp3tag and send the logged events.

I've done more troubleshooting, and may have figured out what's causing the hanging. I've tried both the Windows & macOS versions. The Windows version hangs when trying to add album art to certain FLAC files. When attempting to write album art to the same FLAC files in macOS I receive the error "cannnot write tags to file". I then copied the troublesome files to my MBP. I was thinking the temp folders and temp file were causing the hang....they weren't.
I'm thinking now it's my Windows install and an issue with the Synology NAS. Eventhough the Windows machine has a wired connection, it's like writing the album art causes the NAS to slow to a crawl. I don't know what else it could be. Thank you for your assistance.