Importing UTF-8 without BOM fails

bug-fixed

#1

Hello,

I found out a couple of hours ago that when I try to import tags from a text file encoded as UTF-8 without BOM, Mp3tag apparently reads the file as ANSI, as all the non-ANSI characters turn out garbled.

E.g. if I have a simple text file:

ó | ’ | á | ℥

And import it in Mp3tag as, say, %comment%, I get the comment:

ó | ’ | á | ℥

However, other tools such as Notepad++ (my preferred text editor) and even the basic Windows Editor interpret and display the file correctly as UTF-8-NOBOM.

I'm not quite sure if I'm missing something here, but searching the forum and looking through the options I couldn't find anything. I do know about the "Write BOM", but that really only does something for writing files. It just seems like such a basic thing, so I really hope this report isn't a dupe.


#2

Hi there.
I had exactly the same problem, but I just found out how to solve it. :rolleyes:

  1. Check this Mp3Tag help page
    http://help.mp3tag.de/options_export.html

Go the bottom or search for the word "BOM" in your browser. :wink:

  1. Check the screenshot I uploaded. It will show you exactly how to set this on Mp3Tag.
    Exit and reopen Mp3Tag, because it only writes the settings on exit.

  2. After that you should Export all your text files again, with this on your export file:
    $filename(my_text_file.txt,utf-8)

  3. Now you can safely use the Convert from Textfile - Tag, with accented words.

Hope this helps. :slight_smile:



#3

Hello, your proposal looks to me that it does not solve the open-posters problem ...
and that your proposal demonstrates the opposite of the open-posters theme.
Still it looks like Mp3tag v2.59b has a problem with UTF-8 text import, when there is no leading BOM.

DD.20140607.0549.CEST


#4

I've changed this with Mp3tag v2.91d so that the import detects UTF-8 also if no BOM is present.


closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.