Is there a glitch in the Feb update?

#1

I'm new to the Community but have been using MP3Tag since I discovered it last year (thanks for the program! ^^) I just opened it today since last using it in Dec18, and am sad cuz it doesn't seem to work anymore.

  1. I have some new files in my music folders which I downloaded in Jan19.
    Today, I can edit the tags of all my previous music (from last year) with no issues but if I edit anything (file name/artist/genre) in the new Jan music files, files seem to become corrupted and won't play. So I've had to revert all changes to keep the music.
    (I've checked my PC and the music files for viruses and they seem to be fine. Also, my new Jan music files are in a sub-folder in my main Music folder, but I tried moving them to my main Music folder and still had the same issues).

  2. Usually, any changes I made in MP3Tag would reflect immediately in my PC which was great.
    Eg if I deleted a music file in MP3Tag, that file would be deleted in my PC's Music folder and put in my Recycle Bin. Also, any Tag editing done in MP3Tag would immediately be reflected in the same file in my PC's music folder.
    But today, any editing isn't reflected at all! The files I deleted in MP3Tag are still in my PC's Music folder (and not in Recycle Bin). My edited tags are not reflected in my PC's music folder. So when I close MP3Tag and re-start it, all the files which I'd deleted earlier come back up and all my tags have reverted back to their original state, sadly not reflecting the few hours of editing I did today.

  3. not sure if this is related, but even the starting up of MP3Tag is taking much longer than usual. Never timed it before but it usually opened up in about 30seconds I think. Today, it takes a lot longer - it stops around halfway through reading half the "tag data" then crawls up each data one by one
    and takes about 3 minutes to start up. (I have about 1800 songs w/w I only added about 140 this January so seems a bit weird that it's suddenly taking several times as long to open up).

I checked the Bugs page and don't seem to see any similar issues reported but have noticed that my version is v2.94 from Feb19 so was wondering if this was an issue from the recent update? I miss how smoothly everything worked last year...

Thanks in advance

0 Likes

#2

ref 2: files are only deleted from the file system if you press Ctrl-Delete. A simple delete only removes them from MP3tags file list.

On the missing tags:
If you edit data in the tag panel, you have to press Ctrl-S to save the changes.

Also, you should check if you have APE tags in the files (filter for them with
%_tag% HAS APE

And if this is so, then check in Tools>Options>Tags>Mpeg which tag types your read, write and delete.
E.g. if you read APE but do not save it then you see the empty APE tags but not the ID3 tags.

ref 1.: it is usually not a virus that hinders files from playing but the files are up the spout somehow.
See the FAQs on how to check file integrity:

0 Likes