ISRC field does not populate

I'm trying to add ISRCsto the MP3's of my own album. I have created a field for ISRC
Screenshot 2023-11-23 ISRC field
However, when I try typing in the field, as soon as I click away, the text (alphanumerical) disappears.
Help, please.

For what kind of music files do you try that?
MP3? FLAC? Something else?

Could you please show us a screenshot from Alt+T as mentioned here?

MP3s - screen shot of what?

Load a song that don't accept your ISRC entry.
Press Alt+T.
Take a screenshot.
Paste the screenshot in your answer.

...and if the title of the extended tags dialogue says something like "APE", then please also show a screenshot of the options Ctrl-O Tags>Mpeg.


ALT T
Ctrl O

This is amazingly helpful. Thanks guys!! :slight_smile:

Thank you for the information.
So far I do not see anything suspicious - only ... if the field is alphanumeric, then ticking "numeric" for sortng and display does not make sense.

Could you try the following:
Select 1 file
Open Convert>Tag-Tag for field ISRC - if you do not find ISRC in the list, type it in.
Format string: exampleNumber
Click OK
Do you see now something (actually exampleNumber) in the file list column for ISRC?

I just tried it in my Mp3tag v3.23 and it worked without any problem:
image

The ISRC is just a random copy & pasted number.

Please follow @ohrenkino's suggestions.

I do not :frowning:
I tried the Convert thing and it came up with the text in the Preview but not on the tag fields.

Just to be sure: Could you please update Mp3tag to the newest official v3.23?
(I see on your sceenshot that you use v3.22 - I don't think this solves the issue, just to exclude this point).

Could you also try the way with the extended tags dialogue?
Alt-T for 1 file,
click the "New" button
Select ISRC as field or type it in
Set a value
Click OK.
Check whether ISRC is in the list of fields
Click OK to save the changes
Check the file list columns
Open the extended tags dialogue again to check if ISRC is still there.

ALT T with value added
Not added
After adding
@ohrenkino
So I selected a track, added the field, clicked OK - the value was not in the columns. Hit Ctrl+T again and it's not there.
This is really confusing.

I suspect I have done something pretty basically wrong when trying to create a new field to carry the ISRCs. I'll give it a few more tries, then delete that field and try to start again.

A wild guess:
Could it be that you have a trailing space after the last % sign in %isrc% in your column definitions?

Guys, you're fab!
I deleted the field entirely and re-created it and it's now working.
I'm sorry to have wasted your time but it was really useful for me to realise that the straightforward "TIOABOA" process works, yet again.

1 Like

Just a side note to your DISCNUMBER content:

Usually the DISCNUMBER is some kind of media counter.
If you release 3 CDs at once, then the DISCNUMBER for the first CD would be 1 or 1/3.

Your current WSCD03 don't really fit in this tag.

Oh thanks!
This the third album - the other two were numbered WSCD01 and WSCD02 so I thought that is what that means but you're saying it's for multi-disk releases, yes? Where there are several disks in the box, as it were.

Exactly. Multiple medias per one release.
Random example:

The DISCNUMBER would be 1/4, 2/4, 3/4, 4/4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.