Issue after upgrading to V3.22

Just upgraded to V3.22 from V3.21 (Win 10 64bit) this morning.
When I load an folder or an album as I have usually done, although mp3tag appears to
read the tag data no data is is displayed on the screen, just the mp3tag fields ie all the fields are empty.
There were no issues with V3.21.
Anyone else having a problem or is it just me?
(Image is of mp3tag on the left..the right side is because I have dual screens)

Ok, just updating... after reading some other posts...if I hit F3 the tracks become visable. But if I display the filter line even with no filter argument in it it does not display the tracks. Even my usual filter aruguments do not seem to work as the did in V3.21 and before.

The filter field seems to contain one whitespace character. Removing that should make everything work as usual.

Could I ask how to remove the whitespace character please? I cannot see anything in the filter field so I tried to hit delete with the cursor on the filter field but this does not seem to do the job.

I also might be wrong in thinking to have spotted the blank. I'd put the cursor in the filter field and hit backspace. To test, you can also use the arrow keys to move back and forth to see if the cursor moves around this potentially existing whitespace character.

What made me assume this: first, it looks like the cursor is not really at the beginning of the field. Second: the right side of the status bar shows that 0/15 files are displayed, which is only happening when the file list is filtered.

I type in a few hundred characters into the filter field...not sure how may it takes to fill it completely...used backspace to remove all these characters I typed in. but still if I have the filter field on no track info is displayed..strange.

In the filter field try Ctrl-A and then press Delete and see if that changes anything.
Also, the statusbar at the bottom shows you how many files are loaded and how many are displayed.

Tried Ctrl-A and Del no change.
With the filter on 0 files loaded
with filter off 30 files are there.
Filter on / off using F3 to toggle.
Have also tried other albums of other HDD's...all FLAC files.
Have rebooted PC also.
Are you able to recreate this on your PC or is it just me?
BTW..I do have quite a few stored filters...probably more than 100.

I can reproduce that if I enter a single character in the filter that the list of displayed files gets reduced to all those that match the filter criterion.
I can also reproduce that if I switch off the filter that all the loaded files are displayed.
I cannot reproduce that if the filter is switched on and "nothing" is entered as filter that the list of files gets reduced.
I can also not reproduce

as on my PC all the files are loaded, only the filter could lead to a reduced list.

The screenshot shows a filter with "#" as filter criterion and the statusbar shows 127 files are loaded but only 1 is displayed. None of the files is selected.

That's interesting...anyway of me reverting back to V3.21 without losing all my previous settings etc?
Also interesting that no one else seems to be having this issue.

... and if these include the strange filter behaviour?

Anyway: see the documentation on how to backup and restore settings:

The previous filters have been used for sometime with V3.21 and earlier..
ok.. bit of a mystery...thank you for your help. If I come up with a solution I will update :slight_smile:

At last I have mp3tag back working as expected at V3.22 (or appears to be at this stage).
I deleted about 30 of my saved filter arguments. After applying that and doing another Ctrl A Del (once or twice) it "magically" worked and can now have the filter panel displayed (with no filter characters typed in it) as well as seeing the tracks at the same time.
So not sure why this issue happened as I have upgraded from one version to another many times on this PC without this issue in the past.
Anyway thanks again for helping me.

Spoke too soon.
I was updating composer and correcting titles etc. All was ok until I used the Filter.
The filter correctly identified what I was looking for but when I deleted that filter I was back with the issue of not being able to see the album info if the filter was on.. but the info was there if the filter is off.
And I cannot get it back to normal the way I "seemed" to recover it before.
So back to the drawing board unfortunately...

You can completely enable/disable the filter using F3, or using the check mark under the menu View>Filter. When toggled off, there shouldn’t be any filter active whatsoever, and you should see all tracks at that point.

Assuming this continues to happen when the filter is active, there is definitely something on the filter box.

Thanks for your input ..
At the moment I am just using it without the filter box on.
Just that the filter comes in handy when or if needed..
If there is something in the filter box then it cannot be seen.
I have held my finger on Delete for ages as well as backspace.

You could try the following:
Save your configuration to a safe place outside the MP3tag folders.
Uninstall MP3tag completely, including all the user settings.
Install MP3tag from scratch.
Check if the filter behaves the way it should.
Save that configuration also in a safe place under a different name than before.
Restore the first saved configuration and see if the filter still behaves the way it should.
If it does not, then you know that something has happened to your configuration at some time way back. You can then restore the new configuration.
If you are adventurous, then you could move one file after the other from the first configuration to the current configuration and see whether everything works as expected.
I suspect that everything will be fine with the actions and exports - only the file mp3tag.cfg may be dangerous.

Saved the old config to another folder on the c drive.
Uninstalled mp3tag using the windows uninstaller in Settings---->Apps & Features.
Ticked the box to uninstall the config data.
Re started the PC
Downloaded another 64bit copy of mp3tag from
Even after reinstalling mp3tag the old filters are still there and it remembers the last folder I have loaded straight after installing without me changing anything.
But have the same issue as before when having the filter box on. Its ok with the filter box off.
So where does the the old filter searches live and how does a new install find the old settings if the old copy was completely uninstalled?
Actions etc seem to be in Data of the saved config.
Update... After all this I deleted manually all my saved filters.
This seems to have rectified the problem.
Now I will have to re input my filters manually.
But at least one or more of the filters seem to cause an issue with V3.22.
Same filters have been saved and in use for many older versions.
Is there a limit on how many saved filters you can have saved?
I will see how it goes this time.
Thanks for your patience.

Are you sure it was uninstalled? Perhaps you still had a 32-bit install from the past that wasn’t uninstalled before you upgraded to the newer 64-bit platform?

Again after adding a few filters the issue has reappeared when the filter box on.
Even with one filter i.e.%title% MATCHES "(?-i)(^| )\b\l+\b"
Its was the 64bit..never installed the 32bit on this PC.
I also tried using CCleaner to check for broken Registry items as well checking that it was uninstalled.
PC is using
Win 10 Pro
OS Build 19045.3393
I am going to try it on someone else's PC when I get a chance.
Must be some sort quirk with mine as no one else seems to be reporting it..
Just something interesting
When I look at Help..About mp3tag..Its says that it is the 64-bit Portable even though I choose the Standard Installation.

I decided to completely uninstall everything I could find mentioning mp3tag.
Installed 64bit mp3tag again.
Only copied across the data file so that I was able to reuse my stored actions.
But unfortunately had to lose all my old filter arguments and start from scratch.
Now at least mp3tag help indicates that it is the standard 64bit standard version and not the portable one.
So at least I am back to normal with all my old filters.
Be nice if there was an easier way of storing the filters.
Thanks again.