Kyrillisch, mal als Fragezeichen, mal diakritisch, mal korrekt

Hallo,
ich versuche russische Tags ordnungsgemäß darzustellen.
Leider ohne Erfolg.
Bei den Dateien gibt es unterschiedliche Darstellunegn

  • bei einigen geht es ohne Probleme
  • bei einigen habe ich diakritische Zeichen
  • bei einigen nur Fragezeichen

Die Dateien mit der korrekten Darstellung stammen nicht von mir und sind nicht in Mp3tag bearbeitet worden.

Mit Mp3tag hab ich es nicht hinbekommen, stellt nur Fragezeichen dar.
Habe alle Einstellungen beim Speichern durchprobiert -> Optionen-> mpeg -> UTF-8, UTF-16, ISO-8859-1.
Leider ohne Erfolg.
Zudem habe ich mit den Aktionen (Quick) experimentiert und dort die Codepage umgestellt, leider auch ohne Erfolg (habe leider nichts an Dokumentation dazu gefunden).

Das es gehen muß, beweist obige Aufzählung.

Hat jemand eine Idee?


Welche Winamp Version ist das? Die Darstellung in Mp3tag ist korrekt?

Winamp 5.5. Das habe ich aber nicht in Verdacht, denn der Screenshot (siehe erstes Posting) zeigt bei anderen Dateien ja die korrekte Darstellung.

Die Darstellung in Mp3tag ist bei den UTFs korrekt, bei ISO erscheinen beim neu einlesen ebenfalls Fragezeichen.

Was für Audiodateien? Mp3?
In welcher Sprache ist dein Windows, deutsch oder russisch?
Zur Sicherheit auf 5.52 updaten

Wenn Mp3, dann am besten ID3v2.3 utf-16 verwenden. Die Tags nochmal speichern [Strg+S]
In Winamp bei einer betroffenen Datei in der ML Alt+3 drücken, schauen ob bei ID3v2 das richtig steht, OK drücken.
Dann eventuell bei der Datei nochmal Rechtsklick > Read Metadata on selected items

So, hab das jetzt mal mit einer jungfräulichen Datei versucht:

  1. ISO - ergibt Fragezeichen

  2. nochmals als UTF-16 gespeichert, ergibt korrekte kyrillische Darstellung in Winamp

  3. Dateien mit alten Tags, die nicht ordnungsgemäß dargestellt wurden, weigern sich nach wie vor.
    Hier wieder Fragezeichen bei UTF-16.

Das Gleiche Phänomen tritt auf bei Nutzung des Tag-Editors JTagger.

Gibt es eine Möglichkeit, die Tag-Infos komplett aus dem Dateikopf zu entfernen? Physisch!
Hab nur gefunden, dass man Tag-Felder entfernen kann. Hab das ebenfalls ausprobiert - ohne Erfolg.

MP3, deutsches Windows

ID3v2 in Winamp ist ohne Einträge. In Mp3tag ist die Option zum Speicher allerdings aktiviert.

Jetzt gehts!

Vielen Dank!

Winamp hab ich auf V.5.52 aktualisiert und die Darstellung ist in Ordnung.
Das ungelöste Rätsel bleibt, warum es vorher je nach Datei drei Varianten gab.

Hallo Forum!

Also erstmal Vielen Dank an Florian für dieses super Proggi!

Das einzige Problem das ich habe ist das hier besagte mit kyrillischen tags.
Sehr wenige tags werden richtig dargestellt aber die meisten leider wie auf dem Screenshot.
Ich vermute mal dass die die richtig dargestellt werden in echtem Unicode gespeichert sind und die falschen als 1251 in Unicode ohne vorherige Umwandlung. Wenn ich den Text ausm Mp3tag in die Zwischenablage kopiere und dann in Word einfüge und anschließend die Schriftart auf eine kyrillische z.B. ER Kurrier 1251(angehängt) umstelle kann ich die Schrift lesen.

Könnte man nicht im Konverter Menü eine Funktion einbauen die die tags über eine bestimmte Kodierung ausliest und dann nach Unicode konvertiert? Wäre echt genial. Die Schrift wird übrigens auch in den unicodefähigem Foobar2000, XMPLay so angezeigt. Winamp nutze ich schon länger nicht mehr und möchte es auch vermeiden.
Habe XP SP2 in Deutsch und alle Programme auf dem neusten Stand.

Edit:Ein sample mit krummem tag hinzugefügt.


BK1251N.zip (31.3 KB)

veselie_rebyata___v_posledniy_ra.mp3 (116 KB)

Dafür gibt es die Aktion "Codepage konvertieren".

Geniiiial. Es klappt wunderbar. Dankee!

Edit: Es gibt nur sehr wenige die eine andere Codepage haben und sich nicht entschlüsseln lassen
Die sehen dann so aus:
ǽ½á ÅÒúáþÑóá - ½¿«¡ ǽÙÕ É«º.mp3
und so
ЗЅїЯб о«Ў - ЗЅјбє.mp3
nach der Konvertierung. Müsste aber auch Kyrillisch sein. Ist aber sehr selten und trat bis jetzt nur bei Dateinamen auf. Die Dateien sind auch unglücklicherweise ohne tags.
Ich kann damit leben.

Hallo,

etwas älteres Thema, aber ich habe das gleich Problem mit den kyrillischen Zeichen.

Die Quickaction hilft auch nicht, aber zum Beispiel die Internetseite http://newyork.mashke.org/Conv/ macht alles richtig.

Hier ein Beispiel:
Ursprünglicher Tag: 9-é ñòàíêàí òåêèëû
nach Quickaction "Convert Codepage" aus Russisch: 9-e noaieai oaeeeu
und die INternet Seite sagt (richtig): 9-й станкан текилы

Nur ist das ewas mühesam mit 10-20 Alben über Copy Paste zu machen.

Kennt jemand eine bessere Lösung? Kann man irgendwie die Quickation anpassen.

Danke im Voraus

Also das Beispiel wird bei mir korrekt umgewandelt.
Hast du unter "Optionen > Tags > Mpeg" bei Schreiben auch eine der UTF-Varianten ausgewählt?
Oder du hast cp 1250 statt cp 1251 gewählt?

Die Umwandlung von
9-é ñòàíêàí òåêèëû
nach
9-й станкан текилы
geht wohl richtig mit Russisch/Ukrainisch, Codepage 1251.

DD.20090808.2155.CEST