Mp3tag 3.22b reading library under windows 11

If mp3tag starts reading the directory (monitored directory), the taskbar no longer works. Active programs are no longer displayed and switching no longer works properly. Likewise, a closed program will not be hidden from the taskbar.

I then have to restart Windows Explorer using the task manager. When mp3tag is started and I'm working in a directory that isn't monitored in the settings, everything works fine. The problem only occurs when I change to a directory that was specified in the options. I've already had mp3tag rebuild the database, but the behavior is the same. I have 52700 entries in the mp3tag db. Cleaning up the db didn't bring any success either

I'm using Windows 11 Build 22H2 22621.2428

To narrow down the problem:
Has it worked before?
If it has: what has changed in the meantime?
Does this happen if you read the previously monitored folders but this time with the library function switched off?

  1. Yes it's worked before
  2. Switch from 10 to 11
  3. No it did not happen when the monitored folders are switched of and the db is not in place

It could be an idea to check the access rights and owner of the MP3tag data folder.

Alternatively: save the configuration in a safe place, uninstall MP3tag completely (check that there is no data folder left over anywhere, not in the %appdata% folder, the program folder, the previous installation folder) and that also the registry shows not more traces.
Then install MP3tag again.
Restore the saved configuration to the new data folder.

I'm a systems administrator. I have the full access for this folder under my appdata directory. I also deinstalled the complete software, clean the registry and than made a new install. The behavior is the same when it comes to reading the db. Without reading a db everything is ok.

Also no changes if t start the program with "Start with Administrator rights".

Being administrator is not the same as being the owner of a folder.
As I cannot look over your shoulder what you have done, I can only give you ideas what to check.

If you really started with a clean installation, then the observations of this thread might be of interest:

I'm also the owner of the folder and the "Windows Defender" is disabled.

It looks to me like access rights are not correct, either for the library or for the watched folder.

The rights are correct - believe me.
That is the error message within the event-log:

Name der fehlerhaften Anwendung: Mp3tag.exe, Version:, Zeitstempel: 0x650a98dd
Name des fehlerhaften Moduls: combase.dll, Version: 10.0.22621.2215, Zeitstempel: 0x05b9e9b5
Ausnahmecode: 0xc0000005
Fehleroffset: 0x000000000013bb00
ID des fehlerhaften Prozesses: 0x0x5070
Startzeit der fehlerhaften Anwendung: 0x0x1DA079C524E433B
Pfad der fehlerhaften Anwendung: E:\Mp3tag\Mp3tag.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\combase.dll
Berichtskennung: a2cc557a-93dd-42d8-b991-a6774616c959
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

See this Microsoft thread about combase.dll:

Please note that the thread says that this library is part of the operating system and should be maintained by it.