Mp3tag Not Able to Access Track

I've been using Mp3tag for several months now, and couldn't be happier. Tonight I ran into a problem I haven't been able to fix. I downloaded several tracks from Amazon, and was fixing the tags on the tracks to my own specif format. For example, I've got a fixed number of genres, and certain ways I group some together (Blues/Blues Rock or Metal/Hard Rock). I also number the tracks in an offbeat way. If a song made the year-end Billboard charts, I use the year and chart position for the track number, like 6310 for a song that was #10 on the 1963 chart.

Tonight I was doing one particular track, and every time I tried to apply my new tags, I got an error message that Mp3tag couldn't access the file. I checked in the folder, and it was not marked "read only" or anything like that. I've tried fiddling around with a couple things, but can't get the program to access the track. I've downloaded about a dozen tracks tonight, and haven't had any problems with the other one.

Any suggestions?

have you ,per chance renamed the folder whilst the contents are open in mp3tag ?

Which were? If you had told us what you did, we would not recommend the same thing again.

The warning is usually issued by the OS that the file is blocked - which is usually caused by another program. You would have to investigate which one that could be and avoid it.

Another cause could be esp. with downloaded files, that the file is corrupt. Check it with the linked utilities: