MP4 and MKV chapters are listed as separate files


#1

Hi,

I am seeing an issue that was NOT present in 2.91, which seems to have started in 2.91A build for mp4.

I have mp4 files built using mp4box which contain chapters, and some others without.
In versions 2.91 and prior, these files appeared correctly in mp3tag, which each file appearing as 1 row within the list as expected, and could be properly tagged.

Starting version 2.91A, mp3tag creates 1 entry per CHAPTER for the mp4 file, with each chapter appearing as a different track. The files cannot be properly tagged by mp3tag any longer as a result.

I have created a very small sample file to help with the investigation (attached).

I believe mp3tag (all versions) also have this same issue with mkv files, but I don't have any mkv files.. Just remember seeing that behavior when I was experiment with an mkv file a long time ago.

IMG_0752.zip (66.2 KB)


#2

I thought the support for chapters was a feature introduced in
[2017-08-12] NEW: added support for Nero-style MP4 chapters.
I found this in the change log:
https://www.mp3tag.de/changelog.html


#3

You're right. What I'm saying is that there has been a regression or change in behavior since 2.91A which is I believe incorrect.

Prior to 2.91A, an mp4 (video) file containing chapters would be one entry, and could be selected and tagged as such, resulting in the whole movie to be tagged (and the chapters were kept in the file). In versions 2.91A and above, each chapter appears as a separate, and each chapter needs to be tagged separately (i.e. if tagging "the first" entry, all other movie segments don't get the tags such as title, artists, etc etc).


#4

I can confirm. The issue also occurs with mkv files. Not sure however if it is regression, i am running 2.91 and it occurs in that version. Never tried editing tags on mkv files in older versions.


#5

I've added an advanced configuration option to toggle listing chapters as separate files with Mp3tag v2.91e. It's disabled by default and you can enable it via "Options > Tags > Advanced".


#6

Thanks. Installed 2.91f this morning and the feature seems to work fine.


#7

Great! Appreciate the feedback :slight_smile: