MP4 / M4A cannot remove some tags

I have some M4A files that have encoder version information (string like Lavf57.41.100) from FFmpeg, and these don't show up in MP3Tag, and this seems to prevent the "MP4" tag from being removed fully.

There are M4A files which do not contain this field, and can actually have the MP4 tags removed fully in Mp3tag. So I think it could be fixed.

This came up because I was trying to find duplicate files, but the fact that two M4A files are the same but with a different encoder version meant that they were hashed differently. I was hoping that Mp3tag could fully remove the tags so the duplicates could be removed, but this was not possible.
Only solution ended up being reprocessing all files losslessly in FFmpeg so that the version string is the same across all files, which is not ideal because FFmpeg does not support overwriting files.

Thank you, hope this report makes sense.

It's not accurate and a little bit unfair to jump to the conclusion that this behaviour is a bug.
A program may not do what you want, but that does not mean it has a bug.

Anyway, here is another solution to your problem, at least for M4A files: use Exiftool not ffmpeg.
Exiftool does not normally write audio files, so I was surprised when it stripped the metadata from an M4A file.
And Exiftool does allow for overwriting files.
It never touches a file's content, only its metadata, so there is no decoding and re-encoding.

for 1 M4A file
to remove all tags from a M4A file and over-write the original
exiftool -overwrite_original -all= "W:\Path\to\directory\afile.m4a"

to remove all tags except the encoder tag from a M4A file and over-write the original
exiftool -overwrite_original -all= -tagsFromFile @ -encoder "W:\Path\to\directory\afile.m4a"

for all M4A files in a directory and all subdirectories, add the -r and -ext options and specify the top directory, like this:
exiftool -r -ext M4A -overwrite_original -all= "W:\Path\to\directory"
exiftool -r -ext M4A -overwrite_original -all= -tagsFromFile @ -encoder "W:\Path\to\directory"

If you remove -overwrite_original from the commands, back-up files will remain.