MP4-Tags with superfluous null bytes at the end are not shown in MP3TAG

I think re-saving the files should do the trick. Just select the files and re-save their tags via Ctrl+S and Mp3tag should fix the null values in the tags.

This is likely the OS replacing the invalid character with an underscore in the folder and filenames.

I am very curious to know where this character is being introduced, as I have never had this problem in the past. When I first started ripping my library to digital 20 years ago, I was using iTunes. Once I found I could do a much better job of tagging with mp3tag, I made a permanent transition - but never did I have these null characters added. Even now if I make a quick change there for a test, it doesn't happen. Does your OS language match what is set for iTunes?

Thank you Florian, this is amazing! I think it worked! I deleted all files out of the iTunes Library used the save button in MP3Tag and readded the Files to iTunes.
As you can see the path structure has changed and the "" sign is not there any more.
Only the file-names still contain the "
"-symbol. But I would guess iTunes did not change the file names, only the path-structure.
But if someone is able to verify, I have uploaded the same song from the beginning again after processing it through MP3Tag:

Here the screen of the Folder-Structure after processing and readding to iTunes:

Thank you so much for working so quickly on this!

Might be the OS. Or I guess iTunes using "_" instead of the NULL-Value, because iTunes is managing the folder-Structure.
However, I have no clue. Most files are bought from iTunes, but not all. However all files seem to have this issue.

It appeared first, when I had duplicates in iTunes. I then deleted half of the files and this is the current state. So when the duplicates appeared in iTunes there was one file with and one without the "_" special character.

It might also be a combination, because after adding the Files to iTunes I then start "Music Center for PC" from Sony to transfer to an Walkman. (before the Software was called MediaGo)

However those are all just guesses. I don't really know where it came from. I at least noticed, that iPods and Apple devices never had issues with those files, but other players at some point did have issues.

Thanks to everyone for working on this! I think we have a solution now. :grinning:

I can see all tags now in mp3tag. However for some reason the AlbumArtistSort tag has an unusual font.

Edit - shortened screen shot to remove personal ID info

Thanks for looking into this! Yes, this is strange with AlbumArtistSort, also in iTunes as you can see in the screen:

Is there also something I could do about? This does not look correct to me.

I think the initial issue is solved, thanks to everyone for helping out! However, this AlbumArtistSort looks very strange to me. I think I sometimes had issues with some players showing some Artist Names two times on some players. This might be because of this Font(?)-Issue maybe?

It looks like a backslash-slash \/ to me. Is it just 1 character?

On this one file, what happens if you type over that and save?

It is a single character. If you look closely, all of the characters are stretched. I'm not sure how or why this would apply across several different programs, as it looks this way in both iTunes and mp3tag.

Yes, in between the two words is just one space(?) character.

I also found it is placed very strangely in the sorting for iTunes-Artists as you can see. It appears after Artists that start with Br:
2022-03-01 18_01_17-iTunes

Also strange as I type into this field, I find several other artists also with this strange Font:

In iTunes through deleting the field and copy-pasting the Album-Artist I can remove the strange font, but after saving it anew it stays the same:

I looked at your original uploaded file with Mediainfo and it looks like this:

As I am not using your internal version I cannot see the albumartistsort-tag with Mp3Tag.
After writing the albumartistsort-tag (soaa) with MP3Tag I see this with Mediainfo:

Those are special Unicode homoglyphs that look like an ASCII character but are instead Unicode characters in the upper Unicode range.

Various Artists

I've also noticed this when inspecting the file, but I've seen wilder things before.

Thanks for looking into this as well! I have no idea how I got homoglyphs into my files :smile:

Is there any way I could fix this? I tried in iTunes manually copying the Album/Künstler into the AlbumPerformer/sort field, but at least in iTunes it did not work out and stayed in that way.

Why are you still using iTunes for tagging after all what we did for you in this topic? :sweat_smile:

I've edited ALBUMARTISTSORT in Mp3tag and it worked without problems.

2 Likes

Yes, you're absolutley right! I'm sorry, why did I use iTunes? :laughing:

I used iTunes for too many years and got used to it. But there is really no reason any more. I don't have any Apple device. And since iTunes messed up my library so much, I'm surely going away from iTunes and won't let it manage and sync my music any more.

This is great, I will of course use MP3Tag now :grinning:
I'll have to look a little more into it. Maybe I can even solve this automatically for all my files with your tool through an RegEx-Expression.

Thanks again for looking into all of this and helping out so much!

Here is a post from the HowTos how to copy one tag field into another:

Even if you have any iDevices and need to keep using iTunes, make sure these preferences in the Advanced tab are both UNchecked to prevent iTunes from modifying or moving any of your files. You can still add new ones by dragging them to the iTunes window or using File>Add File or File>Add Folder menus, but now they will stay where you want them, even on separate drives if necessary.
image

1 Like

Perfect, thank you very much guys! I see this is a great tool! I'm going to study the HowTo-Section a little more :grinning:

2 posts were split to a new topic: Specific MP4 file cannot be opened for writing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.