MP4-Tags with superfluous null bytes at the end are not shown in MP3TAG

Hi everyone,
I have my music in an iTunes-Library and I choose the option to let iTunes manage it all. When I now try to change Tags with MP3Tag, no tags are shown. However they are fully shown in iTunes:


I also reached out to Michael from the iSyncer Tool, and he found out, that the issue is, that there is a Special Character - which is not displayed - at the end of all Tags. iTunes must have added it at some point.
He found out, that the Character added at the End of each Tag is the Unicode value 0x0000 (which means decimal = 0). It is a NULL value. Not Space, but explicitly null.

I would like to be able to edit my Tags also with MP3-Tag, and if possible I would be glad, if I could do a search and replace, to delete all of those NULL-Values.

I hope there is a solution for the problem.

Thanks and Greetings,
Karsten

P.S.: I've tried to upload an example song to test it: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

There is no problem to write meta-data to your file here with Mp3Tag.

As you can see this screenshot from the extended tag-view from Mp3Tag, I added the tag-field TITLE to your file.

I checked this file in mp3tag here, many tags were missing. But in iTunes all showed up. I can also see the tags info correctly using dbPoweramp. @Florian I don’t have this issue when editing my iTunes library files. Perhaps there is some issue with the fact this is a “purchased” m4p file rather than m4a? Is it one of the older DRM protected types that mp3tag cannot access correctly?

As mentioned above, some of the fields have superfluous null bytes at the end and are, thus, omitted but preserved by Mp3tag.

The lengths of those fields is reported as if the null bytes are included, which I would count as broken tags — but some other apps are more tolerant there.

I doubt that this is an issue caused by iTunes, because I think we'd then have heard of this sometime before.

I've uploaded an internal version including a workaround for those types of fields. You should be able to read your files with this version:

https://download.mp3tag.de/support/158828B4-95F2-4CD7-8D28-71B0977E42C8-3-12-1-1/mp3tagv312a1setup.exe

Thank you Florian! This is amazing! Yes, I can see now and edit all the Files.

Is there any option to delete all those Null-Values in the Tags, so that also other players and programs won't have problems with the Tags?

Thank you!
I have the same issue with all of my mp4-Files. Even Apple Lossless (ALAC) converted ones. Only mp3s seem to work. It does not seem to be an DRM-issue, because DRM-free files have the same issue.

I always edited my Tags with iTunes, therefore I thought it is an iTunes-issue. It happened first when through an mistake I had duplicates in the Library. I recognized it through this "_" sign in the Filenames and path structure first a few years ago. However it also happens to newly added files like this one (I only add files through iTunes and it gets copied to the Folders by iTunes and then the name change happens):

I only changed Tags through iTunes, however I also use "Music Center for PC" from Sony to send the files to a Walkman. However I never changed Tags there, but maybe the program did on its own.

I think re-saving the files should do the trick. Just select the files and re-save their tags via Ctrl+S and Mp3tag should fix the null values in the tags.

This is likely the OS replacing the invalid character with an underscore in the folder and filenames.

I am very curious to know where this character is being introduced, as I have never had this problem in the past. When I first started ripping my library to digital 20 years ago, I was using iTunes. Once I found I could do a much better job of tagging with mp3tag, I made a permanent transition - but never did I have these null characters added. Even now if I make a quick change there for a test, it doesn't happen. Does your OS language match what is set for iTunes?

Thank you Florian, this is amazing! I think it worked! I deleted all files out of the iTunes Library used the save button in MP3Tag and readded the Files to iTunes.
As you can see the path structure has changed and the "" sign is not there any more.
Only the file-names still contain the "
"-symbol. But I would guess iTunes did not change the file names, only the path-structure.
But if someone is able to verify, I have uploaded the same song from the beginning again after processing it through MP3Tag:

Here the screen of the Folder-Structure after processing and readding to iTunes:

Thank you so much for working so quickly on this!

Might be the OS. Or I guess iTunes using "_" instead of the NULL-Value, because iTunes is managing the folder-Structure.
However, I have no clue. Most files are bought from iTunes, but not all. However all files seem to have this issue.

It appeared first, when I had duplicates in iTunes. I then deleted half of the files and this is the current state. So when the duplicates appeared in iTunes there was one file with and one without the "_" special character.

It might also be a combination, because after adding the Files to iTunes I then start "Music Center for PC" from Sony to transfer to an Walkman. (before the Software was called MediaGo)

However those are all just guesses. I don't really know where it came from. I at least noticed, that iPods and Apple devices never had issues with those files, but other players at some point did have issues.

Thanks to everyone for working on this! I think we have a solution now. :grinning:

I can see all tags now in mp3tag. However for some reason the AlbumArtistSort tag has an unusual font.

Edit - shortened screen shot to remove personal ID info

Thanks for looking into this! Yes, this is strange with AlbumArtistSort, also in iTunes as you can see in the screen:

Is there also something I could do about? This does not look correct to me.

I think the initial issue is solved, thanks to everyone for helping out! However, this AlbumArtistSort looks very strange to me. I think I sometimes had issues with some players showing some Artist Names two times on some players. This might be because of this Font(?)-Issue maybe?

It looks like a backslash-slash \/ to me. Is it just 1 character?

On this one file, what happens if you type over that and save?

It is a single character. If you look closely, all of the characters are stretched. I'm not sure how or why this would apply across several different programs, as it looks this way in both iTunes and mp3tag.

Yes, in between the two words is just one space(?) character.

I also found it is placed very strangely in the sorting for iTunes-Artists as you can see. It appears after Artists that start with Br:
2022-03-01 18_01_17-iTunes

Also strange as I type into this field, I find several other artists also with this strange Font:

In iTunes through deleting the field and copy-pasting the Album-Artist I can remove the strange font, but after saving it anew it stays the same:

I looked at your original uploaded file with Mediainfo and it looks like this:

As I am not using your internal version I cannot see the albumartistsort-tag with Mp3Tag.
After writing the albumartistsort-tag (soaa) with MP3Tag I see this with Mediainfo:

Those are special Unicode homoglyphs that look like an ASCII character but are instead Unicode characters in the upper Unicode range.

Various Artists

I've also noticed this when inspecting the file, but I've seen wilder things before.

Thanks for looking into this as well! I have no idea how I got homoglyphs into my files :smile:

Is there any way I could fix this? I tried in iTunes manually copying the Album/Künstler into the AlbumPerformer/sort field, but at least in iTunes it did not work out and stayed in that way.