Occasional problem with Letter case edit

Latest beta version (3.05d). I found a peculiar problem: Sometimes I cannot change the letter
case from the keyboard. Shift or Caps Lock do not always work in the fields (for example I tried to change - in the album field - Ii with II and failed). I went back to 3.05c and the problem was solved.

1 Like

Tried to change Ii to II in the album field - works.
Using 3.05d

This is most likely related to this change. Many thanks for reporting!

This is interesting. Was Ii already part of the tag and listed in the drop-down list of the album field when you tried this?

No, I simply entered Ii, selected the i and typed the I over it.

OK, this is most likely not what the OP attempted to do. Normally, existing tags are changed :slight_smile:

Can you retry with the field written to the file and listed in the drop-down list of the album field?

I just did this:
2 Files:
1: Comedy Ii
2: Comedy II
Selected both, opened the dropdown list in the tag panel, saw both entries, selected
Comedy II
Saved the change.
Result: Comedy II

Selected both files again,
Tag panel field shows Comedy II
Try to change it to Comedy Ii -> failed, result is Comedy II
No problem to change it in the files list, though.

PS: it would have been so much easier if there had been an indication where the strange behaviour occurred. It was not at all obvious that this is a problem in the tag panel.

2 Likes

I think if you're missing crucial information to reproduce an issue, it's best to just ask further questions.

This should be fixed now with Mp3tag v3.05e. Thanks for reporting!