Problem parsing JSON with a value that has no wrapped quotes

Here's the file. Beatport by &stevehero v5.0#Search Release_TEMP.src (3.5 KB) The line in question is line 113. I've used this json_select_many "artists" "id" "\\u005c\\u005c"but it's not grabbing the info.

The script is setup to search the release automatically which I'm testing on atm. Deadmau5 - The Remixes (Beatport Expanded Version).

The array is formatted like so:

"artists": [{
      "id": 25274,
      "name": "Luigi Daniell",
      "slug": "luigi-daniell"
    }, {
      "id": 37337,
      "name": "JJ-Jefferson",
      "slug": "jj-jefferson"

Is this a bug @Florian as it gets the name and slug value no problem?

It works when I fix the wrapping with a fix like so:
regexpreplace "(\"id\":\s+)(\d+)" "$1\"$2\""

Just a couple of thoughts as cant follow you example as i'm not sure what the actual issue is but...

have you tried single \ rather than double slash
also id is numeric but i think you are assuming its a string - depends on how the parser works i guess

I know it's not a string. I say that in the title. The separator is not the problem.

It's a bug, or at least a limitation of the feature. I've assumed type string for the selected element which doesn't work for numbers (as in the example).

I've fixed it with Mp3tag v3.03c. Thanks for reporting!

1 Like

I was thinking there was a problem as it was inserting the divider but not the value so it seen it but didn't parse it. Thanks for the fix.